Archived

This topic is now archived and is closed to further replies.

Guest Winston

Weather.dll is crashing my FS9!

Recommended Posts

Hello everyone,Recently I tried to reinstall some PMDG products that didn't go too well. I removed the products, but since that I can't get back into Flight Sim 9 as it crashes just after the caption says "loading weather" during startup. After that, Windows produces an error report that says that there was a fault in Weather.dll. I've gone to the installation disks and replaced the module, but this has not solved the problem. Can anyone tell me what I can try, or if they have run into this problem?Thanks!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hello everyone,Recently I tried to reinstall some PMDG products that didn't go too well. I removed the products, but since that I can't get back into Flight Sim 9 as it crashes just after the caption says "loading weather" during startup. After that, Windows produces an error report that says that there was a fault in Weather.dll. I've gone to the installation disks and replaced the module, but this has not solved the problem. Can anyone tell me what I can try, or if they have run into this problem?Thanks!
Why dont you try at the PMDG forum? they may be able to help you more with Installation problems http://forums1.avsim.net/index.php?showforum=136Mark

Share this post


Link to post
Share on other sites

Hi,If it is happening at 71% then you need to change your Render to Texture the opposite of the way it is now.If you can't get FS04 to load, the you can edit your FS9.cfg file. There is a RendertoTexture line. if it a zero make it a one. If it is a one make it a zero. Save the file and then try to run FS.Thanks,

Share this post


Link to post
Share on other sites

Thanks very much for your replies gents! Jim, I went into fs9.cfg but there was no such line listed ( I did a "Find"). Could that be my problem, and if so, could I insert that line myself ?If I can insert it, under which heading should I do it?Thanks!

Share this post


Link to post
Share on other sites

Hi,Look under the Display Device portion of your .cfg file. It should read RenderToTexture.Thanks,

Share this post


Link to post
Share on other sites

Hi Jim,This is all I found:[DISPLAY.Device.NVIDIA GeForce 7600 GS .0]Mode=1440x900x32TriLinear=1AntiAlias=1

Share this post


Link to post
Share on other sites

Hello,

RenderToTexture
Aswell I don't have this in the FS9.CFG
[DISPLAY.Device.NVIDIA GeForce4 Ti 4600 www.TweaksRUs.com XTreme-G.0]Mode=1280x1024x32TextureAGP=0PanelAsTexture=0TriLinear=1
I don't remember had seen this string in any FS9.CFG I had.Seem's to me .. it's not a default FS9.CFG entry.Any others can confirm ?Regards.bye.gif

Share this post


Link to post
Share on other sites

This is from an untouched CFGStraight off the laptop i use for testing onlyMark

Share this post


Link to post
Share on other sites

Hello,

This is from an untouched CFG
LOL ..Of course it's there also in my FS2004 game ... but that's is not expected to search when some tell Render To Texture in the FS9.CFGSure this parameter must be in the FS9.CFG ... but the string (text) must certainly be different than Render To Texture ....EDITED:
The easiest way to change it is in the Settings as Mark suggests above.
The question here is to change this valor of this parameter in the FS9.CFG when you are not more able to start the game ...
If Render To Texture is set to the default (and I don't rmember which that is), then it will not necessarily appear in the config file
And I have test some changes and checked the FS9.CFG and nothing appeared about "Render To Texture" in the FS9.CFGAnyways methink .. this parameter is not related with the OP problem.Regards.bye.gif

Share this post


Link to post
Share on other sites
Thanks very much for your replies gents! Jim, I went into fs9.cfg but there was no such line listed ( I did a "Find"). Could that be my problem, and if so, could I insert that line myself ?If I can insert it, under which heading should I do it?Thanks!
If Render To Texture is set to the default (and I don't rmember which that is), then it will not necessarily appear in the config file. The easiest way to change it is in the Settings as Mark suggests above.R-

Share this post


Link to post
Share on other sites

Hi I had a similar problem with Weather crashing FS9. It turns out it was the WX stationlist that was corrupt ( using real world weather), I deleted the file from the Weather folder. Upon restart FS9 rebuilds it and all was well again.You could try this if you have run out of ideas. Regards Nic

Share this post


Link to post
Share on other sites

Thank you all for your gracious replies. After some rather exasperating and fruitless attempts to solve this problem, it looks like regrettably I have to reinstall FS9. (Sigh...groan...we're talking days of work here...ah well....)Thanks again guys!

Share this post


Link to post
Share on other sites
Thank you all for your gracious replies. After some rather exasperating and fruitless attempts to solve this problem, it looks like regrettably I have to reinstall FS9. (Sigh...groan...we're talking days of work here...ah well....)Thanks again guys!
There is no way I would do a complete re install for the sake of one DLL !!!Give yourself one day of searching , remove your FS9 cfg, anything , but leave a re install as a last resort !!EDIT do you run AS 6.5

Share this post


Link to post
Share on other sites

Hey Mark, Thanks for your encouragement! I do run AS 6.5.One of the reasons I wanted to do a reinstall was because I'm now seeing a phenomenon where some of the buildings are appearing as white featureless silhouettes.I don't know why or how all this is related, but I thought I'd fix everything with a completely new install.

Share this post


Link to post
Share on other sites
Hey Mark, Thanks for your encouragement! I do run AS 6.5.One of the reasons I wanted to do a reinstall was because I'm now seeing a phenomenon where some of the buildings are appearing as white featureless silhouettes.I don't know why or how all this is related, but I thought I'd fix everything with a completely new install.
Well if you are happy to re install then go for it , we all learn as we progress and each install becomes better than the last!!Have fun :( Mark

Share this post


Link to post
Share on other sites