Sign in to follow this  
Guest Staalplaat

Saitek latest drivers screwup

Recommended Posts

I know there is probably an easy fix for this, but I thought I would post a question.I have the Saitek 3d Gold USB stick. I have had it a couple months with no issues. I see Saitek has a new driver out so I dl'd it and installed it. Now in MSFS2k2, I have no throttle. I pushed the lever up and down and it does nothing. It turns, climbs, lowers flaps...etc like it should, just the throttle has stopped working. Any ideas on how to fix this?PS I have calibrated in windows (ME) and it responds like it should. Just in FS is where it wont' move.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

jsut make sure a axses is assigned to the throttle. see the assigment menu in the fs2002 taskbar. (you know, press alt)

Share this post


Link to post
Share on other sites

So all I have to do is assign either X axis or Y axis as my throttle?

Share this post


Link to post
Share on other sites

Hi DaveNC,I'm not familiar with your particular stick, but the throttle in FS2002 is assigned to the Z axis.On the FS2002 main page click on Settings>Assignments>Joystick Axes. Scroll down to the bottom of the page and click on "Throttle Axis", then click on "Change Assignment". Move the joystick axis, and you're done. You might have to reverse the axis.Hope this helps,

Share this post


Link to post
Share on other sites

nop. the x- and y axsis are your horizontal and vertical axsis used by the stick only. You should have an entry "throttle" for your throttle axsis. you should see "throttle" under the colom "event". Select it and change the assigment.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this