Archived

This topic is now archived and is closed to further replies.

Chock

anyone know how to fix this problem?

Recommended Posts

I've got a weird problem with FSX, the menus only work in windowed mode, when in full screen my mouse cannot select any of them at all, everything in the cockpit can be selected, but not the menus, switch to windowed mode and they work fine. Anyone had that issue and more importantly, anyone know how to fix it? I've already tried binning the config file and doing a repair with the FSX installation disks, but to no avail.Al

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Alright, now this is very weird, and it only happens in FSX in full screen mode, the menus actually are working in FSX, but what made me think they were not is that the pointer arrow is out of alignment with the area of where you can click. Here's a pic showing what I mean, the pointer didn't show up on the screengrab, so I drew the yellow cross and circle to represent about where the pointer arrow is showing up when the menu can be clicked:mouse.jpgAny suggestions other than reinstalling FSX?Al

Share this post


Link to post
Share on other sites

I had something similar happen to me today when I copied over some textures. My FSX resolution got changed to 1024x768 but my monitor was still forcing 1650x1050(?).I fixed mine by cycling through a few different screen resolutions under display options. You should be able to keyboard your way there with Alt-O, letter E, letter D

Share this post


Link to post
Share on other sites

That's weird!You don't use any special mouse driver? You run FSX with exactly the same resolution as your Windows Desktop?No special FSX add on that plays trick with mouse input?

Share this post


Link to post
Share on other sites

I always run games and simulations, at my native monitor resolution. I find they always look best that way. Today I was uninstalling some addons and somehow I blew away my Textures folder. When I copied it back from my laptop, my screen was all stretched out and magnified and I couldn't see any menus. It was really weird looking. I hotkeyed to display and switched my resolution back to 1650 x 1050 and the problem went away. Don't know if you are having the same thing, but looks a lot like mine did. Good luck.Thaellar

Share this post


Link to post
Share on other sites

I was just coming on to say I'd sorted it out, and most of you were right, FSX had somehow decided to track the mouse as though there was a different resolution set in FSX, thus thinking the mouse was in a different location to where it was actually displaying.Knocking everything onto default FSX settings and then manually putting them back to how I had them before 'unstuck' it out of its weirdness. Before I tried that I even went to see if there actually was a driver for my mouse (Logitech Pilot Optical) but it doesn't need one according to Logitech and of course it wasn't the problem anyway.I do normally run FSX at the same resolution as the desktop too incidentally, so I really don't know why this happened, although I have a suspicion it might have occurred when I tried to install the Flight Keeper ACARs panel into the Ariane 737 (don't try that by the way, it messes up all kinds of stuff and stops the 737 working LOL, so it's my guess that was what was behind it all).If I hadn't tried that back to default thing, your suggestions would have got me sorted, so thanks everyone for pitching in with those guesses and things to try.Al

Share this post


Link to post
Share on other sites