Sign in to follow this  
Guest

Joystick does not work with 3D stereo driver

Recommended Posts

I downloaded the latest Deternator Driver 4403 and the latest Nvidia stereo 3D Driver 4403. I found my Joystick does not work when I turn on the Stereo driver. Even if I turn it off the joystick does not work. I can go up and down in pitch, but will not enable me to bank my plane left or right. The only way I can use FS2002 is to end it and restart it. I have a sidewinder Microsoft Joystick, and does not happen with my other games, only FS2002.I have an AMD Duron 1.2 Ghz, 512 DDR Ram, 40 gbyte HD, a Gainward Ti4200 Geforce 4 card.Anyone else have this problem, or have a work around where I can use my Joystick? Tried it without joystick and still does not run, so somewhere something is conflicting when I run the Stereo driver with FS2002.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I don't know whether this will help or not, but I noticed a similar problem after upgrading to DirectX 9.0a. It seems DirectX automatically sets your joystick options to Poll with interrupts enabled. I have a sidewinder and began getting erratic sound until I turned this option off. Even if it doesn't clear up your sound problem you should leave it off anyway.It wouldn't hurt to run the DirectX diagnostics.

Share this post


Link to post
Share on other sites

Where is this option to turn off the poll with interrupts. Don't know where to turn this option on or off?

Share this post


Link to post
Share on other sites

found out how to disable enable the poll option on the internet, but is no help, as it's for Win98. In Xp Home edition polling is not listed in advanced settings, so can not check, uncheck it.

Share this post


Link to post
Share on other sites

Try Gaming Options (or whatever XP calls the joystick control box), then under the Controller IDs tab there's a checkbox to turn off polling.

Share this post


Link to post
Share on other sites

Sorry looked and in no way has XP got this option to turn off polling. The only option in the advanced setting is to be able to pick your joystick, and no box to check, or uncheck at all. Anyone else with XP having the same touble as I am having?

Share this post


Link to post
Share on other sites

>Do you have a dialog box that looks like this?No, XP is totally different. I don't think that the user has control over the poll interrupts in XP, at least I haven't seen those settings anywhere.

Share this post


Link to post
Share on other sites

Good old MS. We wouldn't want to give you too much control over your computer - you might hurt something.

Share this post


Link to post
Share on other sites

I too have had this problem for some time. I do not remember exactly when it started but I am pretty sure that it was with one of the stereo 3D drivers of the 40 series. I have tried several things to fix this to no avail, I think the only option is to go back to one of the older stereo drivers which I really do not want to do since it also means going back to an older driver for the vid card. By the way I am using a Logitech Wingman Force 3D joystick so at least we know that this is not joystick specific. I'll try messing around with this problem a little more tonight and report back if I find anything. If anyone else has any ideas please let us know. Thanks, PhilipAMD XP2400, 512 PC2700 Ram, Geforce 4 TI4600

Share this post


Link to post
Share on other sites

Have you tried using an OLDER version of Windows? (win98SE, etc.)As a retired programmer, AND college student, I note that Microsoft did NOT make a server version due to the number of "control" bugs in XP AND the college refused to "upgrade" to XP because of system control problems with "business" software!!! Possibly you could use Linux, with a VM ware Windows emulator. The primary systems administrator for the college's servers finds this works BETTER than direct windows for system control!!:-lol

Share this post


Link to post
Share on other sites

Solution: press "z" on your keyboard, you are in autopilot.That happens to me too, just press z and you can fly by yourself again.Have a nice flight.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this