Archived

This topic is now archived and is closed to further replies.

Mariopilot

Autopilot madness...

Recommended Posts

Hi all, as stated in the topic title and description, this is the problem I'm having. once AP is engaged, it starts to dash the elvator trim up and down, inititating massive dives....it may be me doing something wrong as well. before departure, I initiate the 3 IRS, set up the currente aitrport location, and wait that 9 minutes for them to sync before starting to taxi. normal takeoff, gear and flaps up (all manual) and then AP on. the madness begins!any clues? (note: i didn'ty set up any route on the FMC, just the initial position, so I was looking to fly VOR-to-VOR by ALT and HDG AP usage)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Culprit discovered: iFly 747 hates joysticks! I have an axis assigned to elevator trim, and:- if I assign it via FS axis assignments, it gets mad, jumping form joy position to 0, where AP should statr to move it where needed, but while doing so, joystick kicks back it ot it's position...- if assigned via direct FSIUPC calibration, AP is fully overridden...No-go for elevator trim axis assignments with this one! unluckily, gauge programming is C++ .GAU, otherwise I could have peeked inside and created a system to get around the problem (it can be done by dumping the values of an un-used axis to the iFLY parameter for the elevator trim and then switch off this process as you turn on AP, but I have no way of finding the variables on C++ programmed gauges, and no way to interface these parameters with a XML code...)another no-go is throttle axes.. i can live without the trim axis on the ifly 747 (all other aircraft assigned via FSUIPC...) but getting rid of the throttles is unacceptable (throt1 to eng 1&2, throt2 to eng 3&4 via FSUIPC, saitek pro flight yoke). I may fly the aircraft on maunal power anyway... now it is flyable at least...

Share this post


Link to post
Share on other sites