Sign in to follow this  
Guest

ATI Radeon 9700 Pro - FPS=6?

Recommended Posts

Well I'll post this up as a seperate topic, in hopes of getting some help.Microsoft Flight Simulator 2004 - FPS: 5-7ASUS P4PE1 GB Corsair memoryP4 3.06ATI Radeon 9700 Pro 128MBWindows XPNot the fastest system out there (I'm waiting for a new Prometia cooling unit to tweak/upgrade again), but it should run faster then 6 fps.Oh yeah, I put all the detail sliders, weather, etc. to minimum and it didn't make more then a 2 FPS difference.The menus also get garbled when I scroll.Methinks it's an ATI driver issue. I'm just not sure I want to redo my system for this game, when everything else runs well.3DMark 2001 SE score is around 14000 with nothing shut down or optimized.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Go to Control Panel, then go to display. Click on settings. Click on Advanced. Click on the Direct3D tab. Turn off (or lower) anistropic filtering. Uncheck the aplication preference box. Experiment.- Martin

Share this post


Link to post
Share on other sites

With those specs you should easily be in the 20s. I have the same graphics card on an AMD 2700+ system that is running the equivilent of a P4 3.0 ghz machine. I have only 512 meg of ram and I am usually pegged to my locked rate of 25. I'm using the Omega drivers v2.4.7.4 which are based on the Catylist 3.6 drivers. Not really much difference between the two that I have noticed so if you have the latest ATI drivers you should be fine. Some things to check:What do you have running in the background on your system. (services, monitors etc) A good place to look at streamlining your operating system is http://www.tweakxp.com/Try running at higher resolutions with lower AA settings. I run at 1600x1200x32 but only 2xAA and 8xAF. Still looks great.Make sure vertical sync is offSome things on my motherboard bios settings that I noticed made a difference:Fast writes off. I may get comments on whether or not this works but in my case it was noticible.If you are running at 8x AGP try 4x AGPGive some of this a shot. All I know is your system should be doing better.Dave

Share this post


Link to post
Share on other sites

During the installation of FS2004, for some unknown reason my existing DX9.0b file got corrupted. Reinstalled both 9.0b and the Cat 3.6's and am back to normal. However, I see a new vid card in the very near future :-roll Steve KCLEP42.2ASUS P4B266Win98SE512RAMATI 64VIVODDR

Share this post


Link to post
Share on other sites

Thanks for the tips.A corrupted directX 9.0b might be it, though all other games are fine.If it was a problem with stuff in the background, I'd think that my 3D Mark score or other games would be suffering FPS hits.Thanks for letting me know that the card at least works ok on some rigs. That's helpful, and gives me room to hope I can get mine working well in the future.

Share this post


Link to post
Share on other sites

After installing DirectX 9.0b again, and the latest ATI Catalyst drivers from the ATI web site I had a brieft moment of happiness.FPS were 90-100.Then I went ahead an re-enabled some details (remember, I'd set everything to minimal for maximum performance).My FPS dropped to around 60-80 FPS.Then I went to my desktop and upped the settings from the default after the drivers were installed to a more manageable 1600x1200+ on my 22" monitor.Back to the game I went, and fiddled with a few more settings.Yeah, I should have stopped while I was ahead.FPS went down to that magical 6.8 FPS. It's as if there was a cap on my FPS at 7.I checked the hardware tab inside the game, and experiemented with different FPS goals, but nothing helped.I then re-set all the sliders to minimal detail(max performance).Still no luck.I then re-booted my system just in case the settings didn't take, or the memory didn't clear.Still no luck. 7 FPS.I re-set my desktop settings to 1200x1024. Nada.I re-booted, closed everything I could down, and re-started FS2004.7 FPS.AIEEEEEEEEEE!Yep, I've minimized the AA settings and everything else is set to max performance within the Windows XP Display/Advanced ATI tabs for OpenGL and Direct3D.This game is cursed for me.

Share this post


Link to post
Share on other sites

I'm back.I re-installed the ATI drivers from the web site, and this time no luck.I'm going to just shelve this one for now. I simply don't have the time or desire to mess around with it in order to get it to work.All my other games work, and I'm not going to do anything foolish like wipe my HD and do a fresh install of Windows XP Pro.When will I learn not to buy a game when it first comes out?

Share this post


Link to post
Share on other sites

Hi. I also had problems with very low FPS on my system. I was getting 6-13 FPS.The settings I needed to change (from my FS2002 default configuration )were:ATI Control panel:Set Anisotropic filtering to no more than 8X in Performance modeIn FS2004:Set Mipmap quality (Under hardware tab in display settings, quite hard to find) to 4-5. This also eliminates the shimmering/flickering autogen textures!These simple settings trippled my framerate, going from 13 FPS to 34 FPS over Tacoma Narrows, just as an example.Other settings, you can set as you like them. I am able to crank almost all sliders fully to the right and still get very good framerates on my system. I play the sim at 1024x768x32 with 4x FSAA, but if you have a good monitor, you can use 1600x1200x32 instead and go with 2x or no FSAA for even sharper visuals.The problem with garbled menus and such will hopefully be fixed in the next Catalyst release, as this is a bug in ATI's drivers.

Share this post


Link to post
Share on other sites

Thanks for your reply.Actually, as I mentioned before I've already tried sliding everything to minimal performance settings.That includes in the ATI control panel.AA is set to 2x.In the game Mimpmap is set at 1.I went through every setting at put them at their minimum. Sound, Weather, etc.For a brief moment after re-installing DirectX 9.0b and the ATI drivers I achieved over 100 FPS. That's about what I would expect from my system with the details turned down. I achieved over 60 fps with the details at a "high" setting.And then the damn game went back to it's old ways and locked at 7 fps.Not that I'm frustrated or anything.

Share this post


Link to post
Share on other sites

I'm not sure where the problem was, but I've got things working again now.Detail set at very high with most options at our near max.FPS varies, but 25-40 FPS over a city or woods with lots of detail.I must say, the sim looks very pretty. The actual ground textures still look muddy, but everything else is much sharper then FS2002.All I did to get the sim to behave was un-install and re-install.When I first started up a flight, the FPS started at 7 fps again, but shortly later climbed up to 100 FPS (with minimal details). The planes flew a LOT smoother then before.Thanks for the tips from everyone. Now I am in a much better mood then before.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this