Sign in to follow this  
HawaiianCondor

HELP! - No Panel Display in FS2004

Recommended Posts

I've recently installed FS2004, and cannot, despite adjusting many settings, get the panel to display in any aircraft. There is just a black rectamgle where it should be. Virtual cockpit and other views are ok. Looks like a video hardware problem as panels display in safe mode. I have a GeForce FX5200 128Mb card running the latest driver (44.03). Op system is Win ME with 256Mb. I have tried all the obvious stuff like adjusting hardware settings both in and out of the game, checking out DirectX, changing colour depths and resolution...all to no avail! I even tried the previous video driver version.Does anybody have any suggestions???DWB.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

>I've recently installed FS2004, and cannot, despite adjusting>many settings, get the panel to display in any aircraft. There>is just a black rectamgle where it should be. Virtual cockpit>and other views are ok. Looks like a video hardware problem as>panels display in safe mode. I have a GeForce FX5200 128Mb>card running the latest driver (44.03). Op system is Win ME>with 256Mb. I have tried all the obvious stuff like adjusting>hardware settings both in and out of the game, checking out>DirectX, changing colour depths and resolution...all to no>avail! I even tried the previous video driver version.>>>Does anybody have any suggestions???Yes, go to http://www.guru3d.com for the 45.20 drivers (beta version). This will correct the problem for you with the FX5200 video card.You will have to install them yourself (there's no "auto-installer), but the process is quite easy and painless. Just extract the files to a new folder (I cleverly named mine c:nVidea 4520 Drivers). Use Control Panel/System/Hardware to display the device list, right click on the entry for the video card, and use the "I will choose the driver" entry to point to the .inf file in your new folder.BillAVSIM OmbudsmanFounder and Director,Creative Recycling of Aircraft Partshttp://catholic-hymns.com/frbill/FS2002/images/fartslogo.jpg

Share this post


Link to post
Share on other sites

Bill is correct, the 45.20's will fix this issue, which apparently is common with Nvidia chipsets and the FX cards in particular.I have a FX 5900 card and this is the only set of drivers that would enable 2D panels for me for FS9 right out of the box.Doesn't fix all the problems, however, it creates problems with menus in full screen mode, which for me is a real problem because when I fly on-line in full screen mode I can't see the Squawkbox menu at all, so I can't enter text.Hopefully, this will get resolved quickly...maybe with the next official update of drivers from Nvidia...regards,

Share this post


Link to post
Share on other sites

There's another option that may work for GEF FX Panel issues.... Under the "Display" section in your FS9.cfg, try adding this line:PanelAsTexture=1This is normally FS2004's default setting--a change in FS2004. It may be that the sim isn't setting this flag properly in FX cards. My other suggestion if this doesn't work, is to disable AA within FS2004 and "Force it" in the driver using Rivatuner. -John

Share this post


Link to post
Share on other sites

"Yes, go to http://www.guru3d.com for the 45.20 drivers (beta version). This will correct the problem for you with the FX5200 video card."Are you telling the man with WinME to use Win2000/XP drivers? Is this workable or does it cause problems?I'm just curious because I have an FX5900, Win98SE and 44.03 drivers and no 2D cockpits without the "PanelAsTexture" fudge.I'll give the other drivers a try if you say they will work with my OS.

Share this post


Link to post
Share on other sites

As far as I know you can't use the WinXP drivers with 98 or ME. I think you and I will have to wait for the release of the 45.20 drivers for 98/ME.I did try the "PanelAsTexture" thing, but it made no difference to my problem with missing 2D cockpit. Did it work for you?David B (DWB)

Share this post


Link to post
Share on other sites

Yes, setting PanelAsTexture=0 restored the 2D cockpits. I still had to go to windowed mode to keep from freezing while accessing the map or kneeboard.Funny, but with an older GeForce card and the 44.03 drivers, the 2D panels were there even without the monkey-business. Too bad it also didn't run as fast.Good luck.

Share this post


Link to post
Share on other sites

You may also want to turn off AntiAliasing (in the video card setting) if you have that enabled. This has been widely discussed.

Share this post


Link to post
Share on other sites

Is there anywhere else than http://www.guru3d.com to get the 45.20 drivers? I've been trying for three days without success. Site says file servers are offline and to try tomorrow. Well, three "tomorrows" have gone by now with no files. :-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this