Jump to content

Archived

This topic is now archived and is closed to further replies.

dante_in_YYC

Tile Access Per Second

Recommended Posts

Hi folks.I'm a new user and very appreciative of all the input and advice that people offer here. It's such a steep learning curve but I enjoy it. I've been flying over my neighborhood in FSX in my C172. I often fly over it in my real C172 so I'm well familiar with what it should look like. Both Bing and Yahoo cover it very well (Calgary, AB).but I'm missing many tiles when I look out the window at various altitudes (ie 5000 feet AGL and 1500 feet AGL)I monitor TP progress (ovals) in a second monitor and I'm noticing two things.1. My tile access per second rates fluctuate wildly. From 400 to 0 in seconds. I fly circles and back and forth patterns over the neighborhood hoping to catch the missing tiles but no luck. See screen capture attached.2. I am getting an error stating: tileproxy.sys: precreate: unsolicited access to '\Program Files .... see screen cap attached I suspect that I'm somehow exceeding a limit somewhere. It's not on my ISP end.Maybe on the BING end?I've got my server source settings as follows:

[bING]cache_folder=D:\TileProxy\cache.bingnetwork_module=libnettilemodule_config="conn=20|rate=2.0|verbose=0|server=http://ecn.t*.tiles.virtualearth.net|path=/tiles/a%s.jpeg?g=%v|quad=0123|balance=0123|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)"min_level=9max_level=17map_version=631level_mapping=9,10,11,14,14,14,15,16,17color_hack=Yescolor_level=13bulk_extend=50

Other settings include:

max_lod=15preload_min_lod=11preload_max_lod=17max_contexts=512

In my FSX CFG file I have:

TEXTURE_MAX_LOAD=512TEXTURE_QUALITY=3IMAGE_QUALITY=0TEXTURE_BANDWIDTH_MULT=80UPPER_FRAMERATE_LIMIT=15

I'm on Windows 7 (64 bit)I'm not sure if I'm missing something. Any advice appreciated.

Share this post


Link to post
Share on other sites
but I'm missing many tiles when I look out the window at various altitudes (ie 5000 feet AGL and 1500 feet AGL)My tile access per second rates fluctuate wildly. From 400 to 0 in seconds. I fly circles and back and forth patterns over the neighborhood hoping to catch the missing tiles but no luck.
I see default roads throughout all the viewable shot. I don't see anything I can recognize as photo imagery. Since you are on W7, do you have the fix/patch for unsigned drivers? Otherwise it may look like it's working but you see only default scenery.
I am getting an error stating: tileproxy.sys: precreate: unsolicited access to '\Program Files ....
Others have mentioned this issue. I don't have TP on my W7 OS yet... but I do get unsolicited access messages sometimes on XP from Svchost running some internal stuff. You may be getting it from background processes like indexing. You might look at system monitor while it happening and see if you can see what process is reading your scenery folder. I do see it if I look at the scenery folder with explorer.
min_level=9max_level=17map_version=631level_mapping=9,10,11,14,14,14,15,16,17

max_lod=15
preload_min_lod=11
preload_max_lod=17max_contexts=512

TEXTURE_MAX_LOAD=512TEXTURE_QUALITY=3IMAGE_QUALITY=0TEXTURE_BANDWIDTH_MULT=80UPPER_FRAMERATE_LIMIT=15

I'd set that preload down to min at least until everything is running right.and disable level mapping; set min/max to 10-19.Start with the simplest basics and get it running correctly, first.There's nothing wrong even with starting with lod_max=11 to see the low res (level 13) layer - that layer cannot be mistaken for default - and then adjust upwards if this works ok to higher levels. Raising just the lod_max only adds on top of what you already have. Best to just leave the level min/max at 10-19, but if you change level mapping, it has to rebuild everything to match.Keep us posted.Loyd

Share this post


Link to post
Share on other sites
I'd set that preload down to min at least until everything is running right.and disable level mapping; set min/max to 10-19.Start with the simplest basics and get it running correctly, first.There's nothing wrong even with starting with lod_max=11 to see the low res (level 13) layer - that layer cannot be mistaken for default - and then adjust upwards if this works ok to higher levels. Raising just the lod_max only adds on top of what you already have. Best to just leave the level min/max at 10-19, but if you change level mapping, it has to rebuild everything to match.Keep us posted.Loyd
So if I understand (because you said lod_max and I'm assuming you meant max_lod) it should be as follows?max_lod=11preload_min_lod=11preload_max_lod=19min_level=9max_level=17map_version=631level_mapping=9,10,11,12,13,14,15,16,17I have tiles loading but it goes from 170 tiles per second in one message and then 0.0 in hte next and stays at 0.0 for 30 or more messages and then suddenly it goes back to 300 per second then next mesage 100 then next message 0.0 etcThoughts?

Share this post


Link to post
Share on other sites

as a follow up, I've attaching a screen cap that was taken place well into a flight. You can see that the tile access is idle despite the fact that there is much to fill in. I've provided a capture of what it should look like based on Bing.Is it possible that I'm being "kicked off" the Bing server due to too many requests?

Share this post


Link to post
Share on other sites
So if I understand (because you said lod_max and I'm assuming you meant max_lod) it should be as follows?max_lod=11preload_min_lod=11preload_max_lod=19min_level=9max_level=17map_version=631level_mapping=9,10,11,12,13,14,15,16,17I have tiles loading but it goes from 170 tiles per second in one message and then 0.0 in hte next and stays at 0.0 for 30 or more messages and then suddenly it goes back to 300 per second then next mesage 100 then next message 0.0 etcThoughts?
Yeah, max_lod - you knew what I meant...Summary:FSX displays from scale LOD8 at the extreme range to whatever you set as Texture resolution in the game - with slider - up to 30cm as far as TP is concerned (LOD 17/level 19). These 10 levels (max) are represented in the 10 ovals of the TP DOS console window AND the same 10 resolutions are permitted by the min_level/max_level parameters. In the normal course of running TP in a default state (no level mapping) you will NOT download or use any level 9 imagery - so I use only the range that FSX/TP uses directly, that's 10-19. I do not use level mapping; it is commented out - which achieves exactly the same thing as listing each resolution in a level mapping statement as you did. Your TP will behave exactly the same as it currently does if you comment that line out also - it is doing nothing for you at all.Since I don't use level mapping there is no reason to ever have the min/max other than the actual FSX usable ranges. max_lod is the real control. The max_lod=11 means TP will make up to level 13 resolution scenery but no more. FSX will 'resample' these scenery tiles just as it does the default ones and continue to show higher display resolutions but you won't see any significant improvement.I offered that number just because there is no mistaking that level of photo imagery for FSX default tiles. The preload numbers...The lowest number is 8 (which I use because I do NOT use the pre-prepared LOD8 scenery that came with this distribution. I you DO use the built-in LOD8 (ie not disabled in the scenery setup) then preload_min_lod=9 as it is in the initial ini.The preload_max_lod=19 you posted is OVER the max. The max is 17 per the comments. LEVEL 19, yes; LOD 17, yes -- they are the same.You can just set this to 17 and not bother adjusting it again. If I limit my max_lod to 11, then the higher Preload max value has no relevance; a cap that isn't needed.The other reason for testing at max_lod=11... This is the BEST that most of the world has and I don't know where you will be flying.You can test LAX at max_lod=17 but if you go across N Africa or up the coast of Chili, then max_lod=11 will avoid wasting resources and HDD space - as there nothing better to see.So, are you seeing any actual photo scenery yet?Loyd

Share this post


Link to post
Share on other sites

×
×
  • Create New...