Jump to content

Archived

This topic is now archived and is closed to further replies.

bkircher

Problems with Alt tabbing out of FSX

Recommended Posts

Hi there guysKinda stumped really. Im running fsx on my new rig, and it runs great when Im actually using the sim, but Im sure Im not alone on this one, sometimes you need to alt tab out of the program to check whatever. I do that quite alot. The problem that I have been having is that, sometimes when I go to go back to the game, sometimes it works, and sometimes it works 50%. So for instance, Ill alt tab out, then ill take my mouse and click on the program 3-5 times on the task bar for it to be called back up, sometimes, it will come back up, but the screen stays black but yet you can hear the sounds if you press p and you can move the mouse over stuff and see the gauges, but the screen remains black... No matter how I try to get the screen to come back if you will, it doesnt work, usually I have to close fsx by ending the program and or it will ctd on its own.Any thoughts?Running w7 sp1x64bitgeforce 520 1 gig3.4ghz intel i7 g28 gigs of ram23 in moniterrunnnig fsx in full screenfsx sp1, 2


img0043x.jpg

Share this post


Link to post
Share on other sites
Guest jahman

The solution is to run FSX in Windowed mode.Then use AutoHotKey with this script to automatically hide the window title bar and edges.Cheers,- jahman.

Share this post


Link to post
Share on other sites
Guest firehawk44
Hi there guysKinda stumped really. Im running fsx on my new rig, and it runs great when Im actually using the sim, but Im sure Im not alone on this one, sometimes you need to alt tab out of the program to check whatever. I do that quite alot. The problem that I have been having is that, sometimes when I go to go back to the game, sometimes it works, and sometimes it works 50%. So for instance, Ill alt tab out, then ill take my mouse and click on the program 3-5 times on the task bar for it to be called back up, sometimes, it will come back up, but the screen stays black but yet you can hear the sounds if you press p and you can move the mouse over stuff and see the gauges, but the screen remains black... No matter how I try to get the screen to come back if you will, it doesnt work, usually I have to close fsx by ending the program and or it will ctd on its own.Any thoughts?Running w7 sp1x64bitgeforce 520 1 gig3.4ghz intel i7 g28 gigs of ram23 in moniterrunnnig fsx in full screenfsx sp1, 2
I can duplicate the black screen 100% of the time by removing the highmemfix=1 tweak from the Graphics section of the fsx.cfg with my system which is about like yours. I place the tweak back in and the problem goes away. I have no other tweaks in fsx.cfg except for the smallpartrejectradius=1 tweak in the Scenery section.Best regards,Jim

Share this post


Link to post
Share on other sites

Thanks very much Jim, you have no idea how frustrating that thing was!!!After removing that line out of the cfg, my atc menu no longer works and my menu no longer shows up.


img0043x.jpg

Share this post


Link to post
Share on other sites

Anyone else care to chime in with this? It seems like anytime I try and access an fsx menu I also get a ctd. Have no idea why.


img0043x.jpg

Share this post


Link to post
Share on other sites
Guest firehawk44
After removing that line out of the cfg, my atc menu no longer works and my menu no longer shows up.
What line did you remove? The highmemfix=1 line should have fixed the alt/tabbing problem and black screen. Best regards,Jim

Share this post


Link to post
Share on other sites
Guest firehawk44
Anyone else care to chime in with this? It seems like anytime I try and access an fsx menu I also get a ctd. Have no idea why.
I did a Google search for fsx menu crash and there is no fix. It could be a multitude of issues including a conflict with an addon program you installed. I would look at that first. What program did you install and this issue started to occur? Did you update your video drivers and the problem started showing up? Did you install FRAPS? or some other 32 bit program? Have you tried making a copy of your FSX.cfg, then deleting the fsx.cfg and letting the sim rebuild the config? This usually fixes most issues and should be done before doing a fsx repair or uninstalling/reinstalling fsx. Also make sure your Windows updates are up-to-date and that you have the latest versions of dotnet 4. You should also have installed all the Microsoft Visuals C++ Redistributables from 2005-2010 as addon developers, including Microsoft use these programs to install the software on your system. I know many of the addon developers and Microsoft install these programs on your system before installing the addon but just in case you should make sure they are there. Hope this helps.Best regards,Jim

Share this post


Link to post
Share on other sites
What line did you remove? The highmemfix=1 line should have fixed the alt/tabbing problem and black screen.Best regards,Jim
Ya I removed that line, but then my atc menu and fsx menu would not appear. You could still click on them, but you just couldnt see them.
I did a Google search for fsx menu crash and there is no fix. It could be a multitude of issues including a conflict with an addon program you installed. I would look at that first. What program did you install and this issue started to occur? Did you update your video drivers and the problem started showing up? Did you install FRAPS? or some other 32 bit program? Have you tried making a copy of your FSX.cfg, then deleting the fsx.cfg and letting the sim rebuild the config? This usually fixes most issues and should be done before doing a fsx repair or uninstalling/reinstalling fsx. Also make sure your Windows updates are up-to-date and that you have the latest versions of dotnet 4. You should also have installed all the Microsoft Visuals C++ Redistributables from 2005-2010 as addon developers, including Microsoft use these programs to install the software on your system. I know many of the addon developers and Microsoft install these programs on your system before installing the addon but just in case you should make sure they are there. Hope this helps.Best regards,Jim
No fraps for me, I have the current version of graphics drivers from nvidia, windows is up to date, and as far as the last 2 go I think I might manually install those. I just had a reinstall one of my fsdt sceneries last night that should have installed the microsoft C....

img0043x.jpg

Share this post


Link to post
Share on other sites
Guest firehawk44

Fraps was just one of the programs I saw on Google that caused the issue for one person. It was a bad install of the program. You have a bad install of an addon and that's causing your problem. Is your dll.xml okay and not corrupted? Nick N even suggested installing Microsoft .Net updates and installing MSV's especially an update to one which is critical - http://www.simforums.com/forums/topic29041.html. Hope you can get it worked out.Best regards,Jim

Share this post


Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    43%
    $10,960.00 of $25,000.00 Donate Now
×
×
  • Create New...