Sign in to follow this  
Guest Matt Johnson

AVSIM site seems to be going wacky

Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

Hi Robert,Beyond the slowness which seems to be getting worse (mostly in the afternoon as I'm sure you all are aware), two other problems have happened lately:- Threads in the MSFS forum get erased. Happened on more than a few threads yesterday and a few others last week: the thread still shows up in the forum listing, but when you click on them they only show the top blue bar with not even a thread title - the rest of the thread is MIA.- Again in the MSFS forum, no new threads were allowed for about 15 hours on Sunday: it simply gave a script error.Just a heads up,Elrond

Share this post


Link to post
Share on other sites

>Can you say, New MSFS Release? ;) Yeah, I believe that was the biggest reason for the problems yesterday. This forum software has always had some difficulties in handling a sudden increase in activity and this is best seen in the fact that threads sometimes get corrupted in the busy forums. Also, since all forums run off the same system, a massive increase in the activity in the MSFS forum can spill over into corrupted threads in other forums, namely the screenshot forum. They had a number of corrupted threads also. Unfortunately, there is little I can do to help those threads unless I'm able to catch it the minute they become corrupted, which obviously is very hard to do.From what I've seen about these corrupted threads is right after the first reply is made that it corrupts on, you have that moment to salvage most of the thread, but if someone else is right behind that person to reply, that reply usually causes the entire thread to be wiped out. I'm afraid this is the nature of the beast when it comes to running a text-deliminated datafile forum on a system with the activity we have. It sometimes cannot keep up with the traffic.Also Elrond, the script errors from yesterday were due to not only the individual threads getting corrupted but I think the index file was corrupted in a major way that was fixed when the forum database was rebuilt for the MSFS forum. I wasn't available when this happened so I cannot be absolutely certain what happened but rebuilding the forums apparently got things going again.Obviously when the next version of MSFS is actually released, I expect to see more of those problems. What we will do about that time I know we are working towards. I'm fairly certain we will have a new system in place before the summer and I'm trying to do some research on suitable forum software. I know I and I think Tom would prefer to stay with the DCForum product line as it has certainly served us well and I have generally like the support. But I do know we most likely need to move to something using MySQL instead of text-deliminated datafiles and I'm afraid we will have to be able to determine with certainty why our first attempt with moving to the new version was such a flop.One thing I hadn't paid as much attention to that I am now is how our user base has steadily grown. When we first started pruning the user accounts of inactive users back at the end of summer last year, we had somewhere around 5000-5500 users. Now when I prune the userlist, we stay somewhere around 6500+. We had some of these database corruption problems even back then, so it would surfice to say that with a 1000 more regular users, we will see even more problems associated to traffic.

Share this post


Link to post
Share on other sites

would better show my theory. Just pulled up the stats for the forums and thought I'd share with those of you wondering about the problems. The stats seem to indicate what I was thinking about yesterday.It's a little hard to read the legend, but the top maroon line is the number of posts, second line is unique visitors, and third line is the amount of activity the log files registered. The last one is somewhat difficult to draw any conclusions about. But as you can see, the amount of posting took a pretty good job yesterday and considering that we have problems on regular days, it is easy to conclude yesterday presented more load for the forums, especially considering that posting is what hits the forums the hardest.

Share this post


Link to post
Share on other sites

Hi Scott,I can imagine the headache the load on this particular system is causing you all and fully commiserate. I wasn't complaining, but informing - I'm actually surprised the system doesn't corrupt more than it does considering its design and the load around here.If you all ever need an extra hand, my time and any skills I can offer are always yours.Take care,Elrond

Share this post


Link to post
Share on other sites

Oh, don't worry Elrond. I didn't feel you were complaining. I just felt that since several raised the issue about the forum performance yesterday, I wanted to offer up my detailed explanation of why I think we are having problems.>complaining, but informing - I'm actually surprised the >system doesn't corrupt more than it does considering its >design and the load around here. You and me both. When some of the staff is ready to pull their hair out about the forums, including myself, I have to remind everyone exactly what this forum has managed to get through for almost a year now as we have steadily grown. Performance cannot get better with more users while using the same equipment; it will only get worse until we are able to change something.>If you all ever need an extra hand, my time and any skills I >can offer are always yours. That is very generous of you, Elrond, and I will certainly keep it in mind.

Share this post


Link to post
Share on other sites

that I can't blame you guys for everything. :-dohSeems they are having their own share of troubles also which is why some of my stuff is "wacky" Seems I was not getting all my packets back and forth. great guys they are, looks like they jumped on the problem pretty fast and things are looking better tonight.You tech guys are just something else.:-beerchugHow the heck do ya keep it together at times?http://www3.telus.net/midget_ice/Radar_small.gifThis ain't no game kid!http://www3.telus.net/midget_ice/Radar_small.gifhttp://www3.telus.net/midget_ice/dansig.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this