Jump to content

Archived

This topic is now archived and is closed to further replies.

CaptainKorhonen

Rudder axis creeping to the left + sticky movement

Recommended Posts

I have a set of Saitek Pro Flight rudder pedals. I'm having a problem with the axis sometimes slowly creeping to the left. This is very annoying as I can't taxi straight for long distances without touching the pedals - the aircraft will make quite a sudden turn to the left and veer off the taxiway if left on its own. A little bit of left or right pressure centers the axis again, however, I have to keep moving the pedals back and forth a bit to avoid the creeping. This does not happen only in FSX, it looks like it's a hardware problem because it shows up in the calibration settings of the pedals and in Saitek's software as well. What's wrong?

 

That's that. Then, another problem, which really isn't a problem but annoying nonetheless: The pedals' rudder thingy is a bit sticky. I find it difficult to make very slight adjustments because the rudder axis sticks to one place, and after increasing the pressure a tad, becomes free again but causes me to "overshoot" the amount of deflection I want. FSX isn't sensitive enough to be affected by this, but I don't really feel like I'm in control of the aircraft because of this. Is there anything I could do to make the movement smoother or should I just throw these in the garbage and get new ones, CH maybe? (The warranty is most likely long gone, due to stuff I will explain below)

 

 

In general, I have not had a good experience at all with Saitek products. First of all, the yoke - its pitch axis was sticky as hell, and despite various modifications and greasing all the stuff inside, it was still sticky. So I got a TM HOTAS Warthog instead, no problems whatsoever with that. Money well spent. Then there are the pedals. The first issue with them was caused by a deadzone at the beginning of the range, it resulted in abrubt brakings when the values jumped from zero to the desired braking value. I got rid of this with FSUIPC calibration. Finally, the toe brake spring connector inside the left pedal broke. I opened the thing up, and after 3 or 4 times trying to fix it and having it break after a few times pressing the brake, I made a new connector out of steel and bolted that on the remaining plastic bit. It's been solid as rock ever since.

 

Hell, after all this crap I'd build my own pedals if I had a CNC machine!  <_<

 

 

~CK

Share this post


Link to post
Share on other sites

×
×
  • Create New...