Sign in to follow this  
SAS795

FO not receiving Captains actions

Recommended Posts

Last night a friend and I tried out this amazing software. After reading the guides and manuals we tried. Here is how it went:

  1. First time we established a connection and my friend acting as a captain had set up a server, I joined and everything worked fine. We could both see each other’s actions which corresponded with what each role could do.

 

We then took a break to get something to eat and then came back to set up a full flight.

 

2.

 

Here is when it gets strange. We establish a connection again, and we execute everything the same way as before. Me acting as FO again, I couldn’t see my friend’s actions (him being Captain), example being him turning on the battery switch when both FO and CA are in the cold and dark panel state. I (the FO) try to put on the “fasten seatbelt sign” and the CA sees this action correctly. Every other FO action is synced up perfectly with the CA, but not the other way around.

This problem continued and we cannot seem to get it to send the CA button actions to the FO.

Here is how we establish a connection:

  1. We connect to each other using a private VPN (Hamachi).
  2. CA hosts a server in LAN
  3. FO connects using the CA IP from the Hamachi network.
  4. Both in the FSX server – the CA load in first.
  5. When he is finished loading – FO load in.
  6. Both in the NGX – we both set panel state cold and dark.
  7. CA then opens Desk Pilot Captain and sets up a server.
  8. He enables FSUIPC (tried doing this after FO connect = no difference)
  9. FO opens Desk Pilot Client and connects to the server using the Hamachi IP once again.
  10. Connection established successfully and CA enables the shared cockpit feature.
  11. FO then doesn’t see CA button actions; BUT CA sees FO button actions in the cockpit.

We have enabled the SDK line in the options.ini and we are using the same livery (PMDG standard for testing). We got it to work the first time we tried, but every try since has been unsuccessful. Please do ask if you have any questions regarding the setup. We hope to hear from you soon, and we look forward to get this software up and running, as we do also see great potential and in depth simulation with this fantastic program.

 

Best regards

Simon and Lukas

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hello,

 

Can both of you run the DP Compatibility Tester.exe located within the installation directory and make sure both of you have added a firewall exception for the client & server. Check the default windows firewall as well.

 

Instructions for the compatibility tester:

 

1: Start your flight simulator

2: Run the DP Compatibility Tester.exe

 

If both of you receive the success message - its a firewall or modem/router issue. If one of you get the 'fail' message - You will need to upgrade to Microsoft Flight Simulator X + SP2 or Acceleration.

 

If you do have Microsoft Flight Simulator X + SP2 or Acceleration and your still receiving the fail message, something is wrong with your simconnect version. I recommend installing the included simconnect.msi. Located in the SimConnect Client folder.

 

Now if both of you have done everything above and are still having issues. Do both of you have PMDG's SP1c installed?

Share this post


Link to post
Share on other sites

Hi Ripjaw!

 

Sorry for the late response, but we got it working now! It was a router and internet problem with my buddy, so it had nothing to do with DP :) We Thank you for this amazing software and we hope to see a similar program for the 777 when the SDK is released :)

Share this post


Link to post
Share on other sites

Hi SAS795

 

Me and my friend are having the same issue when using DP, would you mind telling me what was it that you done to fix your issue?

 

Thanks :)

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this