Sign in to follow this  
SubLogical

Fogged in here!

Recommended Posts

I have the latest FSUIPC 4 AND LINDA in the FSX Modules folder and wondering if I need to purchase or download any other products to get going.  I see a reference to VRInsight and MCP Combo in setting up LINDA and can't figure out what I should do about this?

 

I'm getting an Everything is OK msg for the Warthog Joystick and Throttles,  VRinsight MCP Combo says a setup is required to resolve a mismatch between FSUIPC and LINDA port numbers not matching and I'm not sure how to clear this up.

 

Also, under the FSX FSUIPC configs I'm getting FSUIPC files not found.

 

So I'm stuck here and they're probably simple fixes but I need some help.

 

If anyone can point me in the right direction it would be much appreciated.

 

Ken

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Ken

 

All you need is a fully licenced copy of FSUIPC (not the free one) and LINDA version 1.13.  The references to VRInsight and MCP Combo are there because LINDA was originally written to better interface with these hardware panels. If you don't have one of these, simply go to the Setup MCP Combo page and un-tick the Enabled box to remove the error message you are getting.

 

If FSUIPC is correctly installed (confirmed in LINDA Setup Combo page) you should find it under the FSX Addons menu.

 

I hope that helps.

 

Andrew

Share this post


Link to post
Share on other sites

Thanks for the guidance Andrew.  I'll probably be back begging for tips before I get my wings on LINDA but I'm already enjoying the learning and practical potential of  using this product.

 

It's good to be back on Avsim and flying after a hiatus to "master" (?) ATC.

 

Ken

Share this post


Link to post
Share on other sites

Andrew could I run this by you again as I'm not getting the go ahead from Linda.

 

1) checked that FSUIPC was latest version and a registered copy.  It's running in FS.

 

2) disabled the MCP Combo settings

 

3) Couldn't make any changes to the FSUIPC config box on same page as Combo settings and maybe since VRinsight isn't on board I can forget this box ?

 

4) FSX/FSUIPC configs continues to say "FSUIPC files not found ... setup required" - this one baffles me as all the files in both FSUIPC and Linda are in the "Modules"  file.  I didn't see an errors re installs.

 

Am I still missing something or should I just press on?

 

Ken

 

Share this post


Link to post
Share on other sites

Ken

 

I agree on points 1-3 above. For point 4, take a look in the folder \FSX\modules.  You should have the following FSUIPC files:

 

FSUIPC4.ini, FSUIPC4.log, FSUIPC4 Install.log, FSUIPC.DLL and FSUIPC4.key

 

Check the install.log to make sure your installation was successful and no error reported. 

 

Also check in LINDA under Joysticks to see if any of your devices are shown.  This means that LINDA and FSUIPC are talking to each other.

 

If all else fails try un- and re-installing FSUIPC.  Apart from that I can not suggest anything else to try.

 

Andrew

Share this post


Link to post
Share on other sites

Well I finally found the problem which may be of interest to others having trouble with LINDA error "cannot find FSUIPC files".  The problem was that the FSUIPC.ini was not addressed properly to the LINDA.exe.

 

Below is the first line in the FSUIPC.ini which previously was not properly directed:-

 

[Programs]
RunIf1=C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\Modules\LINDA.exe

 

The above, altered code resolved the error problem.

 

My thanks to Andrew for his determined assistance.

 

Ken

Share this post


Link to post
Share on other sites

Hi Ken

 

I'm glad you got it sorted. The general advice I picked up when I started was not to install FSX or P3D in the default Program Files directory due to admin permission issues. It is far better to install in the root directory (ie. C:\FSX\).

 

Good flying.

 

Andrew

Share this post


Link to post
Share on other sites

HI

I need help with Linda

I use Linda version 1.9; FSX PMDG 737 NGX; registred FSUIPC version 4.9; three USB game controllers for switches; Saitek X52 flight control.

 

I have Linda open, FSX running, I can see all USB game controllers in Linda, I have some switches and Saitek buttons mapped in Linda under Joystick screen. I mapped for example NGX GRD PWR on taken from the list of available NGX commands.

In Linda under Settings I have green Everything OK under Joysticj/HID devices.

I have MCP Combo disabled. FSX/FSUIPC says setup required but when I click on the link, it's doing nothing.

I can Reload LUA engine and see message in FSX that LINDA restarted.

I have a line in FSUIPC.ini RunIf1=C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\Modules\LINDA.exe

 

When I go to FSX NGX and press on any mapped button there is no action at all. 

 

It drives me mad.

Please help.

Share this post


Link to post
Share on other sites

Hi auz068

 

Sorry to hear that you are experiencing problems with LINDA. When you are seeing the NGX functions do you have the PMDG737 running in FSX and the PMDG737 aircraft in the LINDA aircraft selection box outlined in orange (ie. FSX sync pressed)? This is required to ensure that your assignments are correctly stored for that aircraft. Sometimes after loading an aircraft you need to Restart Lua Engine to activate the device buttons.

Share this post


Link to post
Share on other sites

It works now. It's good to know that you need to wait a minute after you press Update. I expected an action immediately after Update and I was saying, not working. The only issue I have now is that the Shift Global only sometimes works. I need to try few times.

Share this post


Link to post
Share on other sites

Glad you got things working. The reset is not instantaneous as we come to expect these days. You have to wait until LINDA reports Ready before operating any buttons.

 

With the Global Shift, you need to make sure that you can get out of it by ensuring that there is a corresponding UNSHIFT or GLOBAL Shift in the Shifted page. This is because once you shift the unshifted function is no longer 'visible' to LINDA.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this