Sign in to follow this  
Handle

Joystick Keeps Failing, Getting Frustrated

Recommended Posts

Okay, wondering if you lot could help me here, seein' as how I'm at the end of the rope.  I've tried just about every suggestion there is, short of going back to Windows 7, which is not an option for me.  Heres the long and the short of it.  When I start up FSX my joystick runs fine, as soon as I try to load into anything of detail I.E. the A3xx Series by Aerosoft, or the PMDG 737 after about around 2 minutes my joystick stops connecting to FSX...Mind you, it's still lit up and functioning via the control panel that Saitek provides, but it just won't work in FSX.  I never had this issue when I used my xbox controller for flight.  Weird thing is, when I go into my FSUIPC.ini the line 

 
[JoyNames]
AutoAssignLetters=No
0=Saitek Pro Flight X-55 Rhino Stick
0.GUID={C1C6E540-B6B9-11E4-8001-444553540000}
1=Saitek Pro Flight X-55 Rhino Throttle
1.GUID={C1C73360-B6B9-11E4-8003-444553540000}
 
is present for now, but if after I load into the NGX, and close out of flightsim, the ini deletes that line all together.
I'm running Windows 8.1, and the X-55 Rhino. I've tried turning off the option that shuts USB ports off in favor of power saving, and I've installed the latest drivers.  Anybody got any suggestions?  Little side note before I forget, my joystick works fine in X-Plane 10.  I hope someone has an answer here, because I know I didn't just spend 200 on a new joystick just to have it not work in my main flightsim.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

This is an automatic message.

 

This topic has been moved from "MS FSX Forum" to "Hardware Controllers & Drivers". This move has been done for a number of possible reasons.

  • The most likely reason is that the post was off topic.
  • The topic could also have contained images or a video that were not appropriate to the original forum it was posted in.
  • The images might not have been "illustrative" or "explanatory" in nature.
  • The topic could have been moved because we deemed it to be more appropriately placed elsewhere.
Please ensure that your posts are "on topic" and contain illustrative images or videos as appropriate. Do not post videos or images just for entertainment purposes anywhere but in the screen shot or video forums. See our image posting rules here.

 

Members who continue to post off topic posts can be denied entry to specific forums in order to reduce and remove the practice. Your cooperation is appreciated.

Share this post


Link to post
Share on other sites

Oddly enough, just did around an hour flight in the Aerosoft Airbus and it went fine, now nothing.  Sitting at the gate for two minutes in the NGX, after two minutes and putting the irs to align, nothing.  FSUIPC still picks up the fact that I have a throttle.  But no joystick.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this