Jump to content

Archived

This topic is now archived and is closed to further replies.

The_avionics_guy

P3d PDK problem - Solved

Recommended Posts

Hi stephen

i installed OpusFSI Release Version 4.48.7 and i have a little problem with the camera module, the weather engine is working fine.When i start opusfsi, i cant control the camera and the dhm is no longer working.

after hours of troubelshooting, i desactivated the p3d PDK module and everything went back and opusfsi is controling p3d cameras systems. I dont undestand why because have the enty set up correctly in dll.xml and i have OpusPDK.dll is in my modules folder.i unistalled opusfsi and simconnect and  reinstalled them,but  didnt solve the problem.

 

can you help me please to fix this problem  stephen.

 

 

thx in advance

kais

Share this post


Link to post
Share on other sites

It works fine here.

 

Run everything up in the usual manner then open the FSISERVER's Spy window. Make sure you see the Connected to Simulator - Prepar3D Mode and Connected to OpusPDK Interface messages confirming the operation.

 

Also check our PDK is loaded first in the DLL.XML file as detailed in the documentation.

 

Stephen :-)

 

The above will make sure you have the correct P3D operating modes selected and it will confirm it is connected to the OpusPDK Interface.

 

Your OpusPDK.dll could be an old version in which case a warning message box should appear. You could copy the current one into the Modules folder. Also double check your DLL.XML file to make sure everything is as it should be. You could remove the launch code and then re-apply it, again launching it first in the list. (email me your DLL.XML if in doubt).

Share this post


Link to post
Share on other sites

Hi stephen

i fixed the problem by deleting prepar3d.cfg file and regenerating it.I don't know what wrong with the old file, but now opusfsi is controlling p3d cameras.

 

thanks again stephen

Share this post


Link to post
Share on other sites
 
 

hi stephen

i have the problem again, i dont know why opusfsi is not controlling p3d with my prepa3d.cfg

can you try this please

[JOBSCHEDULER]
AffinityMask=14
[Display]
ChangeTime=4.000000
TransitionTime=4.000000
TEXTURE_FILTERING=16
MSAA=2
SSAA=0
VSYNC=0
FXAA=1
TRIPLE_BUFFER=0
SKINNED_ANIMATIONS=1
TEXTURE_BANDWIDTH_MULT=30
UPPER_FRAMERATE_LIMIT=40
WideViewAspect=True
FullScreenExclusive=True
FullScreenAutoFill=True
ActiveWindowTitleTextColor=255,255,255
ActiveWindowTitleBackGroundColor=0,28,140,64
NonActiveWindowTitleTextColor=255,255,255
NonActiveWindowTitleBackGroundColor=24,33,87,64
InfoUpperRightTextColor=255,0,0
InfoUpperRightBackGroundColor=0,0,0,0
InfoLowerLeftTextColor=255,255,255
InfoLowerLeftBackGroundColor=255,0,0,128
InfoLowerRightTextColor=255,255,255
InfoLowerRightBackGroundColor=255,0,0,128
InfoBrakesEnable=True
InfoParkingBrakesEnable=True
InfoPauseEnable=True
InfoSlewEnable=True
InfoStallEnable=True
InfoOverspeedEnable=True
InfoWeaponSystemEnable=True
InfoCountermeasureEnable=True
FullScreen=False
[SCENERY]
POP_FREE_AUTOGEN=1
AUTOGEN_BATCH_LOD=2
AUTOGEN_TREE_MAX_DRAW_DISTANCE=9500.000000
AUTOGEN_TREE_MIN_DISTANCE_TO_LOD=2500.000000
IMAGE_COMPLEXITY=2
[Main]
FIBER_FRAME_TIME_FRACTION=0.01
User Objects=Airplane, Helicopter, Submersible, ExternalSim
LabelsSupported=Airplane, Helicopter
Location=440,129,1480,908,\\.\DISPLAY1
Maximized=2
HideMenuNormal=1
HideMenuFullscreen=1
AlwaysFullLoad=1
HIDEINFOTEXT=1
[PANELS]
IMAGE_QUALITY=1
SAVE_AND_LOAD_PANEL_STATE=0
PANEL_OPACITY=100
PANEL_MASKING=1
PANEL_STRETCHING=1
UNITS_OF_MEASURE=0
QUICKTIPS=0
[Weather]
WindshieldPrecipitationEffects=1
MinGustTime=10
MaxGustTime=500
MinGustRampSpeed=1
MaxGustRampSpeed=200
MinVarTime=5
MaxVarTime=50
MinVarRampSpeed=10
MaxVarRampSpeed=75
TurbulenceScale=1.000000
WeatherGraphDataInDialog=0
AdjustForMagVarInDialog=1
DynamicWeather=0
DownloadWindsAloft=0
DisableTurbulence=0
CLOUD_DRAW_DISTANCE=6
DETAILED_CLOUDS=1
OPTIMIZE_DENSE_CLOUDS=1
CLOUD_COVERAGE_DENSITY=8
THERMAL_VISUALS=0
VolumetricFog=0
[CONTROLS]
Controls_Default=Standard
Controls_Current=Standard
KBDAIL=64
KBDELEV=64
KBDRUD=64
[TextInfo.1]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
WindDirectionAndSpeed=1,6
FrameRate=2,1
LockedFrameRate=2,2
AverageFrameRate=2,3
FuelPercentage=2,4
[SlewTextInfo.1]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
WindDirectionAndSpeed=1,6
FrameRate=2,1
LockedFrameRate=2,2
AverageFrameRate=2,3
FuelPercentage=2,4
[DynamicHeadMovement]
LonAccelOnHeadLon=-0.020000
LonAccelOnHeadPitch=-0.010000
RollAccelOnHeadLat=0.010000
YawAccelOnHeadLat=-0.100000
RollAccelOnHeadRoll=0.100000
MaxHeadAngle=5.000000
MaxHeadOffset=0.300000
HeadMoveTimeConstant=1.000000
[VirtualCopilot]
VirtualCopilotActive=0
[GRAPHICS]
MIPMAP_VC_PANELS=1
TESSELLATION=1
TEXTURE_MAX_LOAD=2048
NUM_LIGHTS=4
COCKPIT_HIGH_LOD=1
AIRCRAFT_REFLECTIONS=1
LANDING_LIGHTS=1
DAWN_DUSK_SMOOTHING=1
LENSFLARE=1
HDR=1
BLOOM_LEVEL=2
SHADOW_QUALITY=2
TERRAIN_SHADOW_CAST_DISTANCE=0
CLOUD_SHADOW_CAST_DISTANCE=0
OBJECT_SHADOW_CAST_DISTANCE=2
CONTENT_NO_SHADOW=0
INTERIOR_SHADOWS_CAST=1
EXTERIOR_SHADOWS_CAST=1
SIMOBJECT_SHADOWS_CAST=0
TERRAIN_SHADOWS_CAST=0
VEGETATION_SHADOWS_CAST=0
BUILDING_SHADOWS_CAST=0
CLOUD_SHADOWS_CAST=0
INTERIOR_SHADOWS_RECEIVE=1
EXTERIOR_SHADOWS_RECEIVE=1
SIMOBJECT_SHADOWS_RECEIVE=0
TERRAIN_SHADOWS_RECEIVE=0
VEGETATION_SHADOWS_RECEIVE=0
BUILDING_SHADOWS_RECEIVE=0
SHADOW_NUM_CASCADES_LOW=4
SHADOW_NUM_CASCADES_MID=5
SHADOW_NUM_CASCADES_HIGH=7
SHADOW_NUM_CASCADES_ULTRA=12
GROUND_SHADOW_TEXTURE_SIZE=1024
CLOUD_SHADOW_TEXTURE_SIZE=512
SHADOW_LOG_PARTITION_LOW=0.850000
SHADOW_LOG_PARTITION_MID=0.850000
SHADOW_LOG_PARTITION_HIGH=0.850000
SHADOW_LOG_PARTITION_ULTRA=0.850000
EFFECTS_QUALITY=1
EFFECTS_DISTANCE=1
TEXTURE_QUALITY=3
IMAGE_QUALITY=0
See_Self=1
Text_Scroll=1
[DISPLAY.Device.NVIDIA GeForce GTX 560 Ti  .0.0]
Mode=1920x1080x32
[DISPLAY.Device.NVIDIA GeForce GTX 560 Ti  .0.1]
Mode=1920x1080x32
[TrafficManager]
AirlineDensity=15
GADensity=0
FreewayDensity=0
ShipsAndFerriesDensity=0
LeisureBoatsDensity=0
IFROnly=0
AIRPORT_SCENERY_DENSITY=0
[AContain]
ShowLabels=0
ShowUserLabel=0
ShowLabelManufacturer=1
ShowLabelModel=1
ShowLabelTailNumber=0
ShowLabelDistance=1
ShowLabelAltitude=1
ShowLabelAirline=0
ShowLabelAirlineAndFlightNumber=0
ShowLabelFlightPlan=0
ShowLabelContainerId=0
ShowLabelAirspeed=0
ShowLabelHeading=0
LabelDelay=1000
LabelColor=FFFF0000
[TERRAIN]
LOD_RADIUS=5.500000
TESSELLATION_FACTOR=75
MESH_RESOLUTION=21
TEXTURE_RESOLUTION=28
AUTOGEN_VEGETATION_DENSITY=2
AUTOGEN_BUILDING_DENSITY=1
DETAIL_TEXTURE=1
WATER_REFLECT_CLOUDS=0
WATER_REFLECT_USERAIRCRAFT=0
WATER_REFLECT_SIMOBJECTS=0
WATER_REFLECT_TERRAIN=0
WATER_REFLECT_AUTOGEN_VEGETATION=0
WATER_REFLECT_AUTOGEN_BUILDINGS=0
WATER_REFRACT_CLOUDS=0
WATER_REFRACT_USERAIRCRAFT=0
WATER_REFRACT_SIMOBJECTS=0
WATER_REFRACT_TERRAIN=0
WATER_REFRACT_AUTOGEN_VEGETATION=0
WATER_REFRACT_AUTOGEN_BUILDINGS=0
ENABLE_BATHYMETRY=0
WATER_CLARITY=30
WATER_DETAIL=2
UseGlobalTerrainView=False
[ATC]
AutoOpenAirTrafficWindow=1
UsePilotVoice=1
PilotVoice=0
[INTERNATIONAL]
ASLAT=2
ASLON=1
MEASURE=0
[REALISM]
PFactor=1.000000
Torque=1.000000
GyroEffect=1.000000
CrashTolerance=1.000000
General=1.000000
UnlimitedFuel=False
AllowEngineDamage=True
TrueAirspeed=False
AutoCoord=True
RealMixture=True
StressDamage=True
GEffect=True
ManualLights=True
GyroDrift=False
CrashWithDyn=True
CrashDetection=True
OnCrashAction=0
AutoTrim=False
[ATTACHMENTS]
WeaponHighlight=False
HighlightDuration=1.000000
AutoWeaponSwitching=False
UnlimitedWeapons=False
UnlimitedCountermeasures=False
IgnoreAttachmentWeight=True
IgnoreAttachmentForces=True
[RECORDER]
RecordAITraffic=True
RecordAirportVehicles=True
RecordLeisureBoats=True
[SIM]
SYSCLOCK=0
OPTIMIZE_PARTS=1
[SOUND]
SOUND=1
SOUND_QUALITY=2
SOUND_LOD=0
PrimaryPlaybackDevice={DEF00000-9C6D-47ED-AAF1-4DDA8F2B5C03}
VoicePlaybackDevice={DEF00002-9C6D-47ED-AAF1-4DDA8F2B5C03}
VoiceCaptureDevice={DEF00003-9C6D-47ED-AAF1-4DDA8F2B5C03}
[STARTUP]
DEMO=0
STARTUP_DEMO=
LOAD_SIMDIRECTOR=1
LoadWindow=1
[USERINTERFACE]
PAUSE_ON_LOST_FOCUS=0
PROMPT_ON_EXIT=1
SITUATION=F:\Documents\Prepar3D v2 Files\eham default
SHOW_SCENARIO_WINDOW=0
RestoreTimeOnMove=0
SHOW_MISSION_CAPTIONS=0
Map_Orientation=2
[PointOfInterestSystem]
CycleSetting=0
[FACILITIES]
COUNTRY=
STATE=
CITY=
GTL_BUTTON=4096
[Misc]
Com_Rate=7
[MULTIPLAYER]
condAccoutPassword=0


and here's my opusfsi spy message:

 GEN  Input Device 1 : Saitek Pro Flight Yoke
 GEN  Site Effects : 97 Opus, 0 User, 97 in Total
 SIM  Connected to Simulator - Prepar3D Mode
 SIM  Connected to OpusPDK Interface
 SIM  Air Folder = PMDG 737-800NGX WL
 MET  Dynamic Weather Not Updated

 

can you please try if my prepa3d.cfg is working fine for you?

 

thanks in adavance

Share this post


Link to post
Share on other sites

I have no problem with our P3D (never have had), nor have we any reported problems by anyone of the thousands using P3D. I have been using it with no problems whatsoever this weekend.

We do NOT use AffinityMask and have nothing to do with it, nor any need of it.

You had best check your own P3D setup and revert back to a more normal and default P3D operation. Check your DLL.XML file. Email me your XML file if you wish. The OpusPDK should be loaded first and of course specified as a trusted DLL.

This seems like nothing more than the OpusPDK.dll not being loaded into your P3D. So as before just go back to using a normal setup for your sim. First try removing the DLL use and Opus configuration. Get it working again using SimConnect. Then use our setup instructions to enable the OpusPDK Interface again.

Double check your camera definitions. Are your camera definitions actually being used and hence the eye point set for your VC camera views.

Stephen :-)

Why not do as before and delete the P3D CFG and then just leave it once you've got everything working again. You've probably just removed the trusted status of the OpusPDK DLL and hence P3D will not load it.

There are advice on repairing FSX trusted DLL problems.

I still say it's best to revert back to SimConnect. Then set up for the OpusPDK Interface again, you should be asked if you Trust the DLL again, say Yes and then once it's working leave it.

 

Here's my Prepar3D.cfg file content if that will help,

 

[Display]
ChangeTime=4.000000
TransitionTime=4.000000
ActiveWindowTitleTextColor=255,255,255
ActiveWindowTitleBackGroundColor=0,28,140,64
NonActiveWindowTitleTextColor=255,255,255
NonActiveWindowTitleBackGroundColor=24,33,87,64
InfoUpperRightTextColor=255,0,0
InfoUpperRightBackGroundColor=0,0,0,0
InfoLowerLeftTextColor=255,255,255
InfoLowerLeftBackGroundColor=255,0,0,128
InfoLowerRightTextColor=255,255,255
InfoLowerRightBackGroundColor=255,0,0,128
InfoBrakesEnable=True
InfoParkingBrakesEnable=True
InfoPauseEnable=True
InfoSlewEnable=True
InfoStallEnable=True
InfoOverspeedEnable=True
InfoWeaponSystemEnable=True
InfoCountermeasureEnable=True
SKINNED_ANIMATIONS=1
TEXTURE_BANDWIDTH_MULT=30
UPPER_FRAMERATE_LIMIT=20
WideViewAspect=False
FullScreenExclusive=True
FullScreenAutoFill=True
FullScreen=False
TEXTURE_FILTERING=4
MSAA=2
SSAA=0
VSYNC=0
FXAA=1
TRIPLE_BUFFER=0
[sCENERY]
POP_FREE_AUTOGEN=1
AUTOGEN_BATCH_LOD=2
AUTOGEN_TREE_MAX_DRAW_DISTANCE=9500.000000
AUTOGEN_TREE_MIN_DISTANCE_TO_LOD=2500.000000
IMAGE_COMPLEXITY=2
[Main]
User Objects=Airplane, Helicopter, Submersible, ExternalSim
LabelsSupported=Airplane, Helicopter
Location=936,0,2556,1053,\\.\DISPLAY1
Maximized=0
HideMenuNormal=0
HideMenuFullscreen=1
[PANELS]
IMAGE_QUALITY=1
SAVE_AND_LOAD_PANEL_STATE=0
PANEL_OPACITY=100
PANEL_MASKING=1
PANEL_STRETCHING=1
UNITS_OF_MEASURE=0
QUICKTIPS=1
[Weather]
WindshieldPrecipitationEffects=1
MinGustTime=10
MaxGustTime=500
MinGustRampSpeed=1
MaxGustRampSpeed=200
MinVarTime=5
MaxVarTime=50
MinVarRampSpeed=10
MaxVarRampSpeed=75
TurbulenceScale=1.000000
WeatherGraphDataInDialog=0
AdjustForMagVarInDialog=1
DynamicWeather=0
DownloadWindsAloft=0
DisableTurbulence=0
CLOUD_DRAW_DISTANCE=6
DETAILED_CLOUDS=1
OPTIMIZE_DENSE_CLOUDS=0
CLOUD_COVERAGE_DENSITY=6
THERMAL_VISUALS=0
VolumetricFog=1
[CONTROLS]
Controls_Default=Standard
Controls_Current=Standard
KBDAIL=64
KBDELEV=64
KBDRUD=64
[TextInfo.1]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
WindDirectionAndSpeed=1,6
[TextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
GForce=1,3
FuelPercentage=1,4
[TextInfo.3]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
WindDirectionAndSpeed=1,6
FrameRate=2,1
LockedFrameRate=2,2
GForce=2,3
FuelPercentage=2,4
[slewTextInfo.1]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
[slewTextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
[slewTextInfo.3]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
FrameRate=2,1
LockedFrameRate=2,2
[DynamicHeadMovement]
LonAccelOnHeadLon=-0.020000
LonAccelOnHeadPitch=-0.010000
RollAccelOnHeadLat=0.010000
YawAccelOnHeadLat=-0.100000
RollAccelOnHeadRoll=0.100000
MaxHeadAngle=5.000000
MaxHeadOffset=0.300000
HeadMoveTimeConstant=1.000000
[VirtualCopilot]
VirtualCopilotActive=0
[uSERINTERFACE]
SHOW_MISSION_CAPTIONS=0
PAUSE_ON_LOST_FOCUS=1
PROMPT_ON_EXIT=1
SITUATION=C:\Users\Opus Software\Documents\Prepar3D v2 Files\DEFAULT
SHOW_SCENARIO_WINDOW=1
RestoreTimeOnMove=0
Map_Orientation=2
[PointOfInterestSystem]
CycleSetting=0
[sOUND]
PrimaryPlaybackDevice={DEF00000-9C6D-47ED-AAF1-4DDA8F2B5C03}
VoicePlaybackDevice={DEF00002-9C6D-47ED-AAF1-4DDA8F2B5C03}
VoiceCaptureDevice={DEF00003-9C6D-47ED-AAF1-4DDA8F2B5C03}
SOUND=1
SOUND_QUALITY=2
SOUND_LOD=0
[GRAPHICS]
TEXTURE_MAX_LOAD=1024
NUM_LIGHTS=4
COCKPIT_HIGH_LOD=1
AIRCRAFT_REFLECTIONS=1
LANDING_LIGHTS=0
DAWN_DUSK_SMOOTHING=1
LENSFLARE=1
HDR=0
BLOOM_LEVEL=2
SHADOW_QUALITY=2
TERRAIN_SHADOW_CAST_DISTANCE=0
CLOUD_SHADOW_CAST_DISTANCE=1
OBJECT_SHADOW_CAST_DISTANCE=2
CONTENT_NO_SHADOW=0
INTERIOR_SHADOWS_CAST=1
EXTERIOR_SHADOWS_CAST=1
SIMOBJECT_SHADOWS_CAST=0
TERRAIN_SHADOWS_CAST=0
VEGETATION_SHADOWS_CAST=0
BUILDING_SHADOWS_CAST=0
CLOUD_SHADOWS_CAST=1
INTERIOR_SHADOWS_RECEIVE=1
EXTERIOR_SHADOWS_RECEIVE=1
SIMOBJECT_SHADOWS_RECEIVE=0
TERRAIN_SHADOWS_RECEIVE=1
VEGETATION_SHADOWS_RECEIVE=0
BUILDING_SHADOWS_RECEIVE=0
SHADOW_NUM_CASCADES_LOW=4
SHADOW_NUM_CASCADES_MID=5
SHADOW_NUM_CASCADES_HIGH=7
SHADOW_NUM_CASCADES_ULTRA=12
GROUND_SHADOW_TEXTURE_SIZE=2048
CLOUD_SHADOW_TEXTURE_SIZE=512
SHADOW_LOG_PARTITION_LOW=0.850000
SHADOW_LOG_PARTITION_MID=0.850000
SHADOW_LOG_PARTITION_HIGH=0.850000
SHADOW_LOG_PARTITION_ULTRA=0.850000
EFFECTS_QUALITY=1
EFFECTS_DISTANCE=1
TEXTURE_QUALITY=3
IMAGE_QUALITY=0
See_Self=1
Text_Scroll=1
MIPMAP_VC_PANELS=1
TESSELLATION=1
[TrafficManager]
AirlineDensity=25
GADensity=25
FreewayDensity=2
ShipsAndFerriesDensity=2
LeisureBoatsDensity=2
IFROnly=0
AIRPORT_SCENERY_DENSITY=1
[AContain]
ShowLabels=1
ShowUserLabel=0
ShowLabelManufacturer=1
ShowLabelModel=1
ShowLabelTailNumber=0
ShowLabelDistance=1
ShowLabelAltitude=1
ShowLabelAirline=0
ShowLabelAirlineAndFlightNumber=0
ShowLabelFlightPlan=0
ShowLabelContainerId=0
ShowLabelAirspeed=0
ShowLabelHeading=0
LabelDelay=1000
LabelColor=FFFF0000
[TERRAIN]
LOD_RADIUS=4.500000
TESSELLATION_FACTOR=85
MESH_RESOLUTION=21
TEXTURE_RESOLUTION=25
AUTOGEN_VEGETATION_DENSITY=2
AUTOGEN_BUILDING_DENSITY=2
DETAIL_TEXTURE=1
WATER_REFLECT_CLOUDS=1
WATER_REFLECT_USERAIRCRAFT=1
WATER_REFLECT_SIMOBJECTS=0
WATER_REFLECT_TERRAIN=0
WATER_REFLECT_AUTOGEN_VEGETATION=0
WATER_REFLECT_AUTOGEN_BUILDINGS=0
WATER_REFRACT_CLOUDS=0
WATER_REFRACT_USERAIRCRAFT=0
WATER_REFRACT_SIMOBJECTS=0
WATER_REFRACT_TERRAIN=0
WATER_REFRACT_AUTOGEN_VEGETATION=0
WATER_REFRACT_AUTOGEN_BUILDINGS=0
ENABLE_BATHYMETRY=0
WATER_CLARITY=30
WATER_DETAIL=2
UseGlobalTerrainView=False
[ATC]
AutoOpenAirTrafficWindow=1
UsePilotVoice=1
PilotVoice=0
[iNTERNATIONAL]
ASLAT=2
ASLON=1
MEASURE=0
[REALISM]
PFactor=1.000000
Torque=1.000000
GyroEffect=1.000000
CrashTolerance=1.000000
General=1.000000
UnlimitedFuel=False
AllowEngineDamage=True
TrueAirspeed=False
AutoCoord=False
RealMixture=True
StressDamage=True
GEffect=True
ManualLights=True
GyroDrift=False
CrashWithDyn=True
CrashDetection=True
OnCrashAction=0
AutoTrim=False
[ATTACHMENTS]
WeaponHighlight=False
HighlightDuration=1.000000
AutoWeaponSwitching=False
UnlimitedWeapons=False
UnlimitedCountermeasures=False
IgnoreAttachmentWeight=True
IgnoreAttachmentForces=True
[RECORDER]
RecordAITraffic=True
RecordAirportVehicles=True
RecordLeisureBoats=True
[sIM]
SYSCLOCK=0
OPTIMIZE_PARTS=0
[sTARTUP]
DEMO=0
STARTUP_DEMO=
LOAD_SIMDIRECTOR=1
LoadWindow=1
[FACILITIES]
COUNTRY=
STATE=
CITY=
GTL_BUTTON=4096
[Misc]
Com_Rate=7
[DISPLAY.Device.NVIDIA GeForce GTX 580.0.0]
Mode=2560x1600x32
[MULTIPLAYER]
condAccoutPassword=0


Here's my DLL.XML file content,

 

<?xml version="1.0" encoding="Windows-1252"?>

 

<SimBase.Document Type="Launch" version="1,0">
  <Descr>Launch</Descr>
  <Filename>dll.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
  <Launch.Addon>
    <Name>OpusPDK</Name>
    <DLLType>PDK</DLLType>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>Modules\OpusPDK.DLL</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>FSUIPC 4</Name>
    <Disabled>False</Disabled>
    <Path>Modules\FSUIPC4.dll</Path>
  </Launch.Addon>
</SimBase.Document>
 


You can email me your P3DSERVER.CAM if you wish and I will check your camera definitions.

 

I'm sure if you disable the OpusFSI PDK Interface in the Configure dialog and remove the OpusPDK.DLL loading instructions, run everything using SimConnect, then set it up and trust the OpusPDK.DLL again all will be OK. Wouldn't advise messing with AffinityMask though, can't offer advice over its use as we don't bother with it.

 

I can't really mess with my P3D as I use and need it to test the software with.

 

Stephen :-)

Share this post


Link to post
Share on other sites
 
 

hi stephen
Since my last message, i didnt had a problem with opusfsi pdk dll, today i installed the last beta and i have this message, when i fire up p3d.
OpusPDK.dll out of date
The opuspdk library in you p3d modules folder is not fully compatible with the current opusFsi version.please refer to the opuspdk_setup.txt in your opusfsi folder or the opuspdk setup guide in the configure dialog for instructions.
 
what i did i removed the opuspdk.dll from the modules directory, uninstalled opusfsi, reinstalled it , i checked my modules folder and find the opuspdk.dll there ,but when i start opusfsi i have the same message.
 here my dll.xml

 

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
  <Descr>Launch</Descr>
  <Filename>dll.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
  <Launch.Addon>
    <Name>ObjectFlow</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>J:\P3D\ORBX\FTX_AU\FTXAA_ORBXLIBS\Scenery\ObjectFlow_P3D.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>OpusPDK</Name>
    <DLLType>PDK</DLLType>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>Modules\OpusPDK.DLL</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>PMDG HUD interface</Name>
    <Disabled>False</Disabled>
    <Path>PMDG\DLLs\PMDG_HUD_interface.dll</Path>
    <DllStartName>module_init</DllStartName>
    <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>
  <Launch.Addon>
    <Name>carenavigraph</Name>
    <Disabled>False</Disabled>
    <Path>.\carenavigraph.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>CMeteoXml</Name>
    <Disabled>False</Disabled>
    <Path>.\CMeteoXml.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>PMDG Interface</Name>
    <Disabled>False</Disabled>
    <Path>PMDG\DLLs\PMDG_Interface.dll</Path>
    <DllStartName>module_init</DllStartName>
    <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>
  <Launch.Addon>
    <Name>RAASPRO</Name>
    <Disabled>False</Disabled>
    <Path>.\RAASPRO\RAASPRO.dll</Path>
    <DllStartName>module_init</DllStartName>
    <DllStopName>module_deinit</DllStopName>
  </Launch.Addon>
  <Launch.Addon>
    <Name>FSUIPC 4</Name>
    <Disabled>False</Disabled>
    <Path>Modules\FSUIPC4.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>VistaMare Core</Name>
    <Disabled>True</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>VistaMare\ViMaCoreX.dll</Path>
  </Launch.Addon>
</SimBase.Document>

this problem is getting me crazy

 

thanks in advance stephen

Share this post


Link to post
Share on other sites

OpusFSI Beta Version 4.50.1 is now available for download on our website.

Posted a revised beta on 5th April, 07:50 Zulu.

This beta corrects the glitch in P3D mode causing the FSISERVER to report an 'out of date' OpusPDK library.

Regards
Stephen smiley9.gif

Share this post


Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    33%
    $8,485.00 of $25,000.00 Donate Now
×
×
  • Create New...