• 0
Sign in to follow this  
mattathin

--fov Is Being Ignored?

Question

I'm currently running FlightGear 3.0.0 and using it to run 8 slave computers that use individual projectors to project their image onto a large wrap-around display. I'm using simple batch files to start up FlightGear on each slave. I think I have done all the correct steps and everything seems to be working well except for the fact that the field of view for each image that I have set a specific value for has been ignored and has defaulted to 55 degrees (causing overlapping between all the edges). It seems that when "--fdm=external" (or "--fdm=null") is inputed the "--fov=xx.x" is ignored because I tested it excluding "--fdm=external" and the images were all perfectly calibrated but when you try to fly, each slave goes haywire because "--fdm=external" has to be on. The slaves require different --fov values since the projectors are various distances away from the screen. Any suggestions on what I can do to fix this problem? Thanks.

 

Below is an example batch file of one of the slaves:

C:/Program Files/FlightGear/bin/Win64/fgfs.exe ^
  --fg-root=C:/Program Files/FlightGear/data ^
  --fg-scenery=C:/Program Files/FlightGear/data/Scenery;C:/Program Files/FlightGear/scenery;C:/Program Files/FlightGear/terrasync ^
  --aircraft=f-14b ^
  --control=joystick ^
  --disable-random-objects ^
  --prop:/sim/rendering/random-vegetation=false ^
  --disable-panel ^
  --disable-sound ^
  --disable-hud-3d ^
  --disable-ai-models ^
  --disable-ai-traffic ^
  --disable-real-weather-fetch ^
  --enable-fullscreen ^
  --geometry=1920x1080 ^
  --bpp=32 ^
  --disable-terrasync ^
  --disable-fgcom ^
  --fdm=external ^
  --native-fdm=socket,in,60,,5511,udp ^
  --native-ctrls=socket,in,60,,5512,udp ^
  --fov=50.2 ^
  --prop:/sim/view/config/heading-offset-deg=65.4 ^
  --prop:/sim/view/config/pitch-offset-deg=11.1 

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

For the F-14 the default fov is also defined in the *-set.xml (or f14-common.xml on the latest version)

 

Look for the following in the f-14b directory:

 

<default-field-of-view-deg>55</default-field-of-view-deg>

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this