Sign in to follow this  
e911

Win10/FSX Deluxe/ Install error 1611/1628

Recommended Posts

So, I've not been able to find a solution to this anywhere online that works.  I upgraded to win 10 and have been trying to get FSX:Deluxe to install, but it keeps throwing installer errors either 1611 or 1628.  I've tried literally everything found online and nothing seems to correct the issues.  anyone have any thoughts?

 

Thanks.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this