Sign in to follow this  
Skyseek

Active Sky Next Issue w/SimConnect?

Recommended Posts

Windows 10

FSX Delux SP2

SimConnect version 10.0.61259.0

 

I have setup my SimConnect configurations (.xml, .cfg) according to the ASN documentation.  The client is connected to the shared FSX locations on the server properly.  When I look at the SimConnect Log  it shows two IPv4 connections.  Am I missing something?  In the SimConnect XML file I reduced it to just the IPv4 local Settings.

 

0.00000 SimConnect version 10.0.61259.0

 

0.00692 Server: Scope=local, Protocol=IPv4, Address=10.0.0.14, Port=500, MaxClients=64
0.01194 Server: Scope=local, Protocol=Pipe, Name=\\.\pipe\Microsoft Flight Simulator\SimConnect, MaxClients=64
0.01610 Server: Scope=local, Protocol=IPv6, Address=::1, Port=54162, MaxClients=64
0.01945 Server: Scope=local, Protocol=IPv4, Address=127.0.0.1, Port=54163, MaxClients=64

 

0.00692 settings are how I have the client computer configured.  I can ping the server, etc

 

SimConnect XML

 

<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="SimConnect" version="1,0">
  <Descr>SimConnect Server Configuration</Descr>
  <Filename>SimConnect.xml</Filename>
  <Disabled>False</Disabled>

  <!-- Example Local(remote) IPv4 Server Configuration-->
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>local</Scope>
    <MaxClients>64</MaxClients>
    <Address>10.0.0.14</Address>
    <Port>500</Port>
  </SimConnect.Comm>

</SimBase.Document>

 

ASN just sits at Waiting for Simulator status.  Interesting as I am using the SimConnect console = yes option.  When I shut down FSX, the console window stays open until I shut down ASN on the client computer.  Then it closes.

 

 

Any Ideas?

 

Thanks!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The bit that seems odd to me is not that there are multiple IPv4 connections but that one of them is using a port (54163) that is NOT referenced in the SimConnect.XML file.

It would seem reasonable that there is more than 1 client and that each client might try to connect on a different port, but I'm not sure that SimConnect even supports multiple clients on the same protocol using different ports.

 

In your position, I'd want to search for what application is trying to use 54163 and see if I could (temporarily) configure it to use 500. (Incidentally, I recall reading that one should use port numbers above something like 1024 but don't quote me on that. I suppose the important thing is that there are no conflicts.)

 

Sorry - a bit of a vague response but I'm not quite sure what failure your configuration is causing.

 

Cheers,

 

Z

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this