Sign in to follow this  
WebMaximus

Saitek Throttle Quadrant connection issue in Windows 10

Recommended Posts

I'm having a problem with my Saitek TQ where I always have to disable/enable it after I started P3D (2.5). I'm using Windows 10 Pro x64 build 10586.29.

 

What is funny is when using a utility called USBDeview I see that the controller is enabled but still the little green led light on the controller isn't illuminated but becomes after I disable/enable it.

 

Anyone else having this problem and found a solution to it?

 

I guess one thing I could try is to use another USB port.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Howzit WebMaximus

 

Is your Saitek TQ the USB add-on one. I have both the Saitek yoke with quadrant throttle using the round PS/2 connector plugged into the yoke, and the USB add-on one, and I also initially had troubles. I had upgraded my hardware to the top of the line processor, board, RAM and video card, and decided to upgrade W7 Pro x64 to W10 Pro x64. Most of the ports now on this new hardware are USB 3.0 with one or two USB 2.0, and these USB 3.0 are what gave me grief.

 

In my 40 years of my IT experience and 4 years my own business, I have learnt through research and test at many developer sites, that USB 3.0 is not 100% backward compatible to 2.0, typical marketing hype and bullcrap fed to the masses. I learnt that the Saitek yoke refuses to work on any USB 3.0 ports, no matter what tweaking I do in BIOS/UEFI. And the USB TQ was also intermittent. So best bet how I resolved it, was purchased the add-on connectors that screw onto the free space slots on the EFI bus rail at the back of the PC, using the unused USB 2.0 headers on the board, giving me an extra six USB 2.0 ports. And for me I plugged the USB TQ into one of the three free yoke USB ports and added an AC adapter for extra power onto the yoke, it's provided for, but an optional extra as in AC adapter. I also tested the USB TQ straight into the new USB 2.0 ports and all is resolved now. So this is my advice to you and you should have success.

 

One other thing to do to also guarantee the above, and I advise this for all USB port use with high demand devices, is as below. This works for all of the past Windows operating systems in use. I do this as standard practice on all computers, due to the poor ongoing MS and Intel crap with power management to USB.

 

One opens the device manager, type "device manager" without the quotes, into the W10 "Search"

Then click on Device Manager that shows up in the list. Once the Device manager opens it's window, go to the bottom of the list and open the "Universal Serial Bus controllers", by clicking on the little arrow on the left. Then finally right click each and all of the devices listed "....Hubs" select the "Properties" and in the opening window go to the last tab indicating "Power Management" and untick the option that says "Allow the computer to turn off this device to save power". Do this for all of the hubs listed on your system, even those that you plug in externally, plug them in now if they are not plugged in. If you are not sure simply right click all USB devices and click "Properties" on all of them. You will see those that have the "Power management" tab to do this. Uncheck all of them that you find and you will have full power all of the time to any plugged in USB device. You might notice, like my Thrustmaster F16 MFD panels do, that the devices with displays and /or LED's will flash through boot up until you have logged in.
 

But it certainly does resolve the majority of power delivery to high capacity devices attached to USB ports. And especially the dim to non-functioning displays on Saitek panels.

 

If this works for you maybe I should change my handle from Screwbottle to GuruMaximus Hee! Hee! Good luck going forward.

 

Cheers

Andrew

Share this post


Link to post
Share on other sites

Thanks for your input and advice Andrew, I think this might very well be a USB3-related issue.

 

Not sure out of my head if I have any USB2 ports available not already in use but will have a look when I get home. Using any free and internal USB2 headers is also a great idea. I have this feeling though I don't have any of those since they are used for the USB ports built-in into my chassis. I too have a fairly new system where there are lots of USB3 ports but not as many USB2 ports. Let's keep our fingers crossed MS and the hardware manufacturers eventually can work together to address all the USB3 issues we see today and have been seeing for quite some time now. 

 

Very good advice disabling the power management stuff for your USB hubs found in Device Manager. Just like you I've made it into a habit always doing that as one of the first things after I reinstalled my OS.

Share this post


Link to post
Share on other sites

Problem solved after plugging the TQ into another USB port.

 

Funny thing is it was already connected to a USB2 port although via a powered USB hub. Now it's connected to its own USB2 port.

 

So looks like the Saitek TQ doesn't like being connected via a USB hub.

Share this post


Link to post
Share on other sites

Hi WebMaximus

 

As to your reply post no.1, the headers on your board are free from the ones wired onto the board chassis. They use the same chipset, and each internal hub can manage up to four USB ports, most boards/chipsets today actually have six to eight of these hubs with a total of 32 ports, but they don't add all of them. Normally six on the board chassis to the rear, a combination of USB 3.0 and 2.0, and then some on the headers, the rest they don't make provision for.

 

So you should have at least two USB 2.0 headers for use (4 USB ports), and if a new board, your's will also have a USB 3.0 header for the front of chassis use. Check your user manual carefully.

 

As to your reply post no.2, this is usually to do with a poorly screened cable used on the external USB hub, it's generally found on cheap and nasty USB hubs, it fails to control the data flow with too many losses. Good quality external hubs have a cable no longer than 1 metre, and is extremely thick, and not so flexible. It's always a good idea to plug high utility devices directly into the USB ports on the board.

Share this post


Link to post
Share on other sites

Well, now with everything working I'll go with the "Does it work don't touch it" saying but thanks for the additional info - will keep it in mind.

Share this post


Link to post
Share on other sites

You're welcome

 

Yes too true "If it ain't broke don't fix it" in slang is a good line to follow. I tend to swim up rivers against the flow, quoting another human saying going with the flow, much like the Salmon fish. So I say "If it ain't broke, well fix it anyway, as long as you know what you are doing, and accept the consequences". Sorry my weird humour :Tounge:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this