Sign in to follow this  
SniperTNT

Saitek x52 Control Panel Issues

Recommended Posts

I have a Saitek x52 controller, and in the past I would install the drivers and everything would work just fine. Everything did work just fine. I could access the device's control panel by right clicking on the icon in the taskbar and it would show up. There I would be able to configure things like the time on the MFD, the time zones, buttons, sensitivity, etc.

However, today, I tried to access the control panel for the device and it will not open. I can right click on the icon and have the menu open, but if I click on the control panel option, it doesn't do anything more. I really need it to work so I can configure settings and get the few extra buttons that are useful, plus in the case that I need the option to change the sensitivity and dead zones then I would have the option to.

I can access windows' generic version of the device's control panel by going to the windows control panel > devices and printers > then right clicking on the x52 and going to properties, but all that shows is the button test page and it has a calibration page. It does not show the saitek x52 control panel with all of the configuration options.

I have tried installing the latest drivers, rolling back to the ones I had before when it did work, but that didn't do anything. I have tried deleting all of the registry keys for this device and uninstalling the programming software and reinstalling. That didn't work either. I've tried running it as an admin, but that does not work either.

Just so I was sure, I redownloaded the latest windows 10 x64 drivers for the x52 and made sure they were the correct ones. I tried installing them and they install just fine and the throttle works fine, but I still cannot access that control panel no matter what I do.

The familiar part about this is I remember having this problem in the past and it was a simple fix to get the control panel working again. I cannot remember what I did to fix it though.

Any help is appreciated. Thanks.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this