Sign in to follow this  
jack9999

lua error in config-hid

Recommended Posts

Hi,

 

I can't find what is the problem. Maybe someone can help me

In the console, I have the error :

[E] *** LUA Error: ...Simulator X\modules\linda-cfg/system/config-hid.lua : 21 attempt to index global 'JSTK3' (a nil value)

 

I don't understand where is the problem.

 

Do you have an idea ?

 

Thanks

 

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Jack

 

Welcome to the LINDA forum. This is a problem where the devices (joysticks) you have plugged in does not match the ones you had when the file was set up. First ensure all you devices are plugged in. Next try deleting the file config-hid.us in the /modules/system folder. It will rebuild itself automatically. 

 

If that does not work I need to know what version of LINDA you are using and the devices you have connected (see joystick setup). I will need guide you to a solution.

Share this post


Link to post
Share on other sites

Hi ScotFlieger

 

All devices are plugged.

I delete the config-hid.lua but with that I receive another error. HID devices config not found :-)

 

The version is the 2.6.7

 

I have

saitek : radio, yoke, rudder, throtlle

Vrinsight : TTpanel and M panel. but I don't use linda with the M-panel.

 

 

041701300 ● usb pad → Axes: 7  Buttons: 30  Hats: 1  ($2E02EF0)

06A30D050 ● Pro Flight Radio Panel → Axes: 0  Buttons: 24  Hats: 0  ($2E03070)

06A30C2D0 ● Saitek Pro Flight Quadrant → Axes: 3  Buttons: 9  Hats: 0  ($2E031F0)

06A30BAC0 ● Saitek Pro Flight Yoke → Axes: 6  Buttons: 23  Hats: 1  ($2E03370)

Share this post


Link to post
Share on other sites

Please email me to LINDA @awginfosys.net the cconfig-hid.lua following files from:

 

/modules/linda-cfg/system, /modules/linda-cfg/aircrafts/fsx default and /modules/linda-cfg/aircrafts/{your aircraft} - the aircraft that if causing the problem.

 

Also include the file /modules/FSUIPC4.log.

 

What is the USB pad device? Is it the VRi TT PANEL?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this