Sign in to follow this  
mikestrong19

FSXS: Carenado Navigraph 0%

Recommended Posts

I have a couple Carenado aircraft (C90X and the EMB-505 w/ Navigraph add-on) that both do not work with Navigraph data. When attempting to put a route into the G1000 or FMS (depending on the aircraft), no airports or waypoints show up and I am unable to enter anything (i.e. there's something wrong with the nav database). Also, the "Building Navigraph Database" window stays at 0%. I already contacted Carenado and they were unable to figure out the problem. I uninstalled FSX Steam completely (uninstalled, deleted all folders including AppData ones, cleaned registry) and reinstalled it, adding the EMB-505 as the first and only aircraft up to this point. Without installing the Navigraph extension, the default nav database works fine. However, as soon as I installed the Navigraph extension, it was back to where it was before: not even able to input an airport into the G1000.

 

When I was installing both the Phenom 300 originally and the Navigraph extension later, an error concerning dll.xml (screenshot is attached) popped up. I was able to click OK and bypass it. However, when I checked for dll.xml, it was nowhere to be found in any of my AppData folders. I would assume that this is part of (or the whole) issue. It is interesting that the installation seems to be trying to find dll.xml in my FSX AppData folder rather than my FSX-SE AppData folder because I don't have FSX installed (and hence no "FSX" AppData folder). However, there is no dll.xml in the FSX-SE AppData folder either way. Any ideas?

 

kPDZWX0.jpg

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You need this in your dll.xml to fix the 0% naviigraph processing.

 

    <Launch.Addon>
        <Name>carenavigraph</Name>
        <Path>.\carenavigraph.dll</Path>
    </Launch.Addon>

Share this post


Link to post
Share on other sites

You need this in your dll.xml to fix the 0% naviigraph processing.

 

    <Launch.Addon>
        <Name>carenavigraph</Name>
        <Path>.\carenavigraph.dll</Path>
    </Launch.Addon>

 

Well, the thing is that I can't find the dll.xml file and I don't think it exists. It's supposed to be under C:\Users\(my name)\AppData\Roaming\Microsoft\FSX-SE correct? Is there a way to generate or otherwise obtain a new dll.xml? Also, where does that line go in dll.xml? I've heard that the order matters. Thanks

Share this post


Link to post
Share on other sites

OK, I was able to fix it by downloading FSUIPC, which generated a new DLL.xml. I had a dual FSX and FSX:SE install before and probably botched the uninstall of both and reinstall of FSX:SE somewhere along the line. I added that line to the DLL.xml that got generated and it is working well so far. Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this