Jump to content

Sign in to follow this  
wokue

LUA Error

Recommended Posts

Hallo LINDA friends,

after upgrading to latest FSUIPC version I get the following error-message:

 

 

[E] *** LUA Error: ...steamapps\common\FSX\modules\linda/system/common.lua:4314: attempt to compare number with nil

 

 

and LINDA is completly out of busssines.

 

Help is appreciated.

 

regards,

 

Wolfgang

 

Share this post


Link to post
Share on other sites

What version of LINDA are you using?


Andrew Gransden

Scotland, UK

LINDA Support/Developer - VATSIM and BAVirtual - Airbus Flyer

i7 1TB SSD GTX980 - FSX/P3D - Aerosoft Airbus A318/A319/A320/A321 - FS2Crew

Share this post


Link to post
Share on other sites

Hallo Scotflieger,

I`m on Linda version 2.8 latest version and latest version of FSUIPC.  Meanwhile I cleared out that this failure only concerns the Aerosoft Airbus on all the moduls

I`ve available.

I tried multiple combinations of Linda versions and Airbus moduls, they all gave me the bad result.

What me surprises is the fact, that the Linda 2.8 / Airbus 4.x combi went fine until yesterday afternoon, and suddenly things went south.

Couldn`t imagine what I`ve done to trigger this.

BTW  I´m the one with the LSK6R function for the Bus but that should not be the culprit.

Thanks for Looking on to it +

kind regards,

Wolfgang

Share this post


Link to post
Share on other sites

Hi Wolfgang, the error you reported is occurring in the common.lua function DspALTs. Although this function exists, it should not be called in the current Airbus 4.3 module. Can you confirm that you are using a VRInsight Airbus FCU panel? Have you tried to use any of the DspALT functions or added any addition code?


Andrew Gransden

Scotland, UK

LINDA Support/Developer - VATSIM and BAVirtual - Airbus Flyer

i7 1TB SSD GTX980 - FSX/P3D - Aerosoft Airbus A318/A319/A320/A321 - FS2Crew

Share this post


Link to post
Share on other sites

@ Scotflieger,

 

using the old VRI MCP1 panel.  Maybe I tried such a function to see what it is, but is not assigned to a knob. No additional code is added.

regards,

Wolfgang

Share this post


Link to post
Share on other sites

I am having the same issue with the Aerosoft Airbus since updating to 2.8.4 using the MCP II Boeing panel and Saitek panels. Was using 2.6.3 prior with no issues. No panels are working. Linda recognizes all button and switch movements in the UI but they are not reflected in the sim.


VRD001.png

Share this post


Link to post
Share on other sites

I am having the same issue with the Aerosoft Airbus since updating to 2.8.4 using the MCP II Boeing panel and Saitek panels. Was using 2.6.3 prior with no issues. No panels are working. Linda recognizes all button and switch movements in the UI but they are not reflected in the sim.

UPDATE: A full reinstall of LINDA 2.8.4 got my saitek panels working but the Boeing MCP2 is still not working.  I have double checked the setup for it in Linda and it seems correct to me.


VRD001.png

Share this post


Link to post
Share on other sites

UPDATE: A full reinstall of LINDA 2.8.4 got my saitek panels working but the Boeing MCP2 is still not working.  I have double checked the setup for it in Linda and it seems correct to me.

I am about to issue an update (2.8.5) to address reported problems like yours. Please switch on developers mode, tracer and select LUA verbose logging. Restart FSX and LINDA and confirm fault. Then email me at linda@awginfosys.net the files: linda2.log and fsuipc4.log.


Andrew Gransden

Scotland, UK

LINDA Support/Developer - VATSIM and BAVirtual - Airbus Flyer

i7 1TB SSD GTX980 - FSX/P3D - Aerosoft Airbus A318/A319/A320/A321 - FS2Crew

Share this post


Link to post
Share on other sites

I am about to issue an update (2.8.5) to address reported problems like yours. Please switch on developers mode, tracer and select LUA verbose logging. Restart FSX and LINDA and confirm fault. Then email me at linda@awginfosys.net the files: linda2.log and fsuipc4.log.

 

I got it working. Here were the steps I took:

 

1) I copied my Linda linda-cfg folders as you suggest in the install instructions (thank goodness).

2) I deleted all existing Linda folder and files in the Modules folder.

3) Did a fresh reinstall of 2.8.4

4) Copied back in my Aircrafts folders into both the linda and linda-cfg folders.

5) Was still having problems with all panels (Saitek and VRinsight MCP2).

6) Found another forum post that advised that if you have multiple Airbus folders (e.g., A319, A320, etc.) in your modules/linda-cfg/aircrafts folder to get rid of all of Airbus folders as the new linda version uses a single Aerosoft Airbus folder.

7) This got my Saitek panels (i.e., radio, switch, and TPM) working but the VRinsight MCP2 still wasn't.

8) I then copied the config-mcp2.lua file from my old linda-cfg/Aircrafts/Aerosoft Airbus A320 CFM folder and replaced the one in the linda-cfg/Aircrats/Aerosoft Airbus folder and the MCP2 started working.

 

 

So from this I surmise this that there is some difference between the installed config-mcp2.lua and the one I have but I haven't found the difference yet.


VRD001.png

Share this post


Link to post
Share on other sites

I am pleased you have got things sorted and working again.

 

The duplicate Aerosoft Airbus folders would cause your reported problem. A full restart after deleting or renaming the old folders should have got things working.


Andrew Gransden

Scotland, UK

LINDA Support/Developer - VATSIM and BAVirtual - Airbus Flyer

i7 1TB SSD GTX980 - FSX/P3D - Aerosoft Airbus A318/A319/A320/A321 - FS2Crew

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    18%
    $4,640.00 of $25,000.00 Donate Now
×
×
  • Create New...