Sign in to follow this  
gboz

V5: S Key kills Opus cameras

Recommended Posts

Hi again.
I set up a few VC camera views in OpusFSI V5 and they all work fine until I use the "S" key to access P3DV4's default views.
After pressing the keyboard S key or a JS button assigned to the S key (FSUICP) none of my JS Opus assigned views will show.
Also they will not show by clicking on a view listed in the Opus Camera Setup/Edit window.
Only way to get the Opus camera views to show in game again is to reboot the computer.
They will then work until I press the S key again. Problem seems 100% repeatable at the moment.
I'm using Win10, P3DV4, paid FSUICP and LINDA.

Thanks,
gb.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The 'S' key is an internal sim command key that changes the view mode, something that OpusFSI (or any addon) is totally unaware of. Nor can any addon read what the view mode is. If you use the sims internal view mode commands such as the S, Shift-S, A, Shift-A, or manually change zoom levels then you should manually put the view mode, sub-mode, or zoom level back. The sim does not inform addons of such internal view changes.

OpusFSI will reset the mode and zoom level if you switch to an OpusFSI camera that has a different mode (e.g. switching to an OpusFSI External view from a VC view).

So if you use the S key then either use Shift-S to get back to the previous view mode, use press S again to 'cycle' back to the correct mode, or switch to a different OpusFSI view mode by selecting a different OpusFSI camera.

Stephen :-)

Share this post


Link to post
Share on other sites
3 hours ago, Opus Software said:

So if you use the S key then either use Shift-S to get back to the previous view mode, use press S again to 'cycle' back to the correct mode, or switch to a different OpusFSI view mode by selecting a different OpusFSI camera.

Well that's the problem.
If I start with an Opus VC Camera view showing and then say "S Key" to Spot View then "Alt S Key" back to that last Opus Camera VC view then that last Opus Camera is the only one I can get from there on.
All other Opus Cameras do not show when I press their assigned button.

gb.

Share this post


Link to post
Share on other sites

No problem, it's just standard sim operation and has no effect on the OpusFSI camera views.

You can get to (select and display) any OpusFSI Live Camera view. After creating them in Live Camera, just assign a unique button to them (in the Camera Edit dialog for the view) as described in the guide then use that button to select and display the required view on the screen (assuming it has also been assigned to the current selected aircraft). I assign the same button to all similar views for my various aircraft (same button for all VC Captains views etc.). I also assign the same key (x or shift-x) to all my views to cycle within that view mode mode.

Please refer to the Live Camera Manual for details.

Stephen

Share this post


Link to post
Share on other sites

If cameras are not displaying when the button is pressed just open Spy and confirm what event is received when pressing the button. If no event then have you enabled the controller in the sim ? It needs to be enabled in order for the sim to issue the event.

If the event is received and displayed in Spy. Is it still the correct joystick number or do you need to reassign the joystick device list. This can happen if you unplug controllers and plug them in again or use a different USB port.

if it's the correct joystick number then check the camera view in edit mode and make sure it has been assigned to the selected aircraft.

Also make sure the button hasn't been assigned to some other function, in the sim or in any other addon.

There are no reported problems with Live Camera so best check all the above. If stuck then just email me your CAM file and I will take a look at your configuration of your camera views.

Stephen

Share this post


Link to post
Share on other sites
On 04/05/2017 at 1:50 AM, Opus Software said:

There are no reported problems with Live Camera so best check all the above. If stuck then just email me your CAM file and I will take a look at your configuration of your camera views.

Thanks for the replies.
I've been away form the sim for awhile and meanwhile the V5 trial period has ended so will put this issue on hold until a reinstall of the demo version or purchase version.

One thing I notice with V5 and V4 is that Opus gets the names of my controllers wrong sometimes.
Like if I assign a button on my Warthog JS to a camera view, while the Warthog JS button works correctly in selecting that view in the sim, in the Spy Window the controller activating the view is listed as my Desktop Aviator switch panel.
Some other controller names are mixed up while some others are correct. ??

gb,

Share this post


Link to post
Share on other sites

The device list is nothing to do with Opus. All Opus can do is read the device list using DirectX but there's no guarantee the sim will adopt the same order. Furthermore the sim does not allow that ordering to be examined or read.

So just use our Joystick Remapping function via the Live Camera, Shortcuts, or Panning Sequence dialogs. You can remap the controller numbers to match the sims ordering.

Stephen

Share this post


Link to post
Share on other sites
1 hour ago, Opus Software said:

You can remap the controller numbers to match the sims ordering.

Ok, thanks,

gb.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this