pedrodowd

[Resolved] Simconnect? P3d will not communicate with any other Addons.

Recommended Posts

Hi Guys

I recently did a full system rebuild and am having issues with what I think is simconnect.  I can't seem to get p3d to communicate with any of my addon applications. I am running both P3D and all addon programs like active sky 2016 and ezdok v2 on the same machine.

 

When I load asn 2016 it starts fine and downloads the weather without problem. 

 

For instance, when I then start P3D, asn stays at 'waiting for sim' and does not connect to the sim. Ezdok also indicates it is unable to connect through simconnect.

 

I have installed all of the simconnect versions located in the p3d redist folder, and have installed all the c++ runtime libraries from 2005-2015, both x86 and x64. I have uninstalled-reinstalled these and the simconnect versions multiple times but still get the same result. 

 

I have disabled windows defender and the firewall and have no other spyware or antivirus programs running. 

 

I have even performed a complete os re-install including reformatting the sdds with the same result.

 

None of the programs are installed on the program files x86 folder.

 

I  have installed all of the .net frameworks. 

 

I have made sure that defender has all the relevant folders in the exclusion list app data roaming, local, the sim folder and asn folder even though it is disabled. 

 

I enabled full read write modify permissions for all the folders on all the drives using the security tab in windows.

 

I currently only have asn and p3d v3.4.22.19868 installed 

 

Is there a security setting somewhere in windows that perhaps I have missed, as this is a completely fresh install of the latest windows which has been updated, perhaps I have missed something?

 

I'm completely pulling my hair out trying to fix this, I think I've tried everything listed in the forums from various developers. 

 

Thanks in advance for any help you can provide, I've just spent a small fortune on a new system and have a lot of money invested in many addons! 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I go over troubleshooting SimConnect issues in my P3D Guide here: 

 

Cheers, Rob.

Share this post


Link to post

Hi Rob,  thanks for your quick reply. Will head over and take a look now! Enjoying the videos too! 

Thanks again

Pete

Share this post


Link to post

Had a look at the excellent guide, specifically at the simconnect and asn sections. I have all the simconnect versions installed, and have configured asn to look at the correct folders (main p3d folder and appdata/roaming folder. The simconnect versions are showing in add remove programs.  I also have no duplicate exe and dll xml files. 

Share this post


Link to post

I did this with a client last week works perfectly: Installed Win10, the first user has all the privileges needed, installed P3D where it wants to go 'C:\Program Files (x86)\Lockheed Martin\Prepar3D v3', added Modify permission to the Users group on that folder (fixes the access issue with addons stored in that folder and enables Notepad to edit files and stuff like that without the need to run as admin), Installed the four simconnect.msi, 1.0.20.0, 60905, 61242, 61259, only after that I installed addons, worked great.

Share this post


Link to post

setup a SimConnect.ini and turn on logging per my doc ... run P3D with your add-ons then check the SimConnectxxx.log (xxx = 000-999)

Add the SimConnect.xml and add the SimConnect.cfg using your own PC's IP - you shouldn't need SimConnect.cfg for local stand alone.

Report back on any info in SimConnectxxx.log.

Cheers, Rob.

EDIT: I don't recommend you install P3D into C:\Program Files (x86) ... not because of P3D, but because of some add-ons ... however, with that said, Steve's permissions change should also work but be aware that's reducing security ... but there again, so is "Run As Admin" ... but personally I prefer just installing P3D outside or Program Files ... something like C:\Lockheed Martin\...

Share this post


Link to post

It's possible if you have a file like 'C:\Users\[you]\Documents\Simconnect.cfg' could cause it, try renaming it if you have it.

Share this post


Link to post

Firstly Rob, and Steve, thank you very much for taking the time to try and help me get this figured out. The fact that people are willing to take the time to help others in difficulty, makes this little community of ours great. 

I'm pleased and relieved to say I FIXED the problem! I had forgotten that the Microsoft cloud storage app would be putting files in my documents folder when I logged into windows for the first time.  Although I was on a completely new system with formatted hard drives, the cloud (somehow) remembered the simconnect.cfg from when I had asn on a networked pc ages ago. It placed the file back in my documents and this it seems was preventing any apps from talking to P3D.  As soon as it was removed, ezdok and active sky are now working! 

Thank you both again for your help, 

Pete

  • Upvote 2

Share this post


Link to post

Glad it's sorted out OK Pete. Thanks for the explanation, a bit of a funny one!

Steve

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now