Matthew Allen Schuld

Freezing about 20 minutes after take-off

Recommended Posts

I am having an issue where FSX is freezing about 10-20 minutes after takeoff. The entire computer freezes and requires a restart. I did not have this issue prior to the install of Radar Contact. Any suggestions on what I can do so I can keep using this great product?

 

Thanks!

Matt

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Matt,

It's unlikely to be related to RC4. Is the freezing constant whatever airport you fly out of?

Can you post more info including hardware specs? Is there any entry in Event Viewer that might give a clue to the problem?

What message does FSX display? The sim has stopped responding?

Share this post


Link to post
Share on other sites

System specs, AMD FX 9370 8core 4.4ghz

16 gb Ram

64 bit Windows 10

I'm also running Little Navmap via little navmap connect as you mentioned earlier.

 

FSX doesn't display any message. Everything freezes, audio, graphics, etc... Ctrl, alt, delete, doesn't work. I have to do a hard reset. Freezing has happened at every airport.

 

Here are the event viewer logs in reverse chronological order. I think these are right, but I'm not sure what time it actually failed last night. Your help is truly appreciated.

 

Log Name:      System
Source:        Microsoft-Windows-Kernel-Power
Date:          8/3/2017 9:14:15 PM
Event ID:      41
Task Category: (63)
Level:         Critical
Keywords:      (70368744177664),(2)
User:          SYSTEM
Computer:      Schuld
Description:
The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-Kernel-Power" Guid="{331C3B3A-2005-44C2-AC5E-77220C37D6B4}" />
    <EventID>41</EventID>
    <Version>5</Version>
    <Level>1</Level>
    <Task>63</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8000400000000002</Keywords>
    <TimeCreated SystemTime="2017-08-04T01:14:15.795778000Z" />
    <EventRecordID>7186</EventRecordID>
    <Correlation />
    <Execution ProcessID="4" ThreadID="8" />
    <Channel>System</Channel>
    <Computer>Schuld</Computer>
    <Security UserID="S-1-5-18" />
  </System>
  <EventData>
    <Data Name="BugcheckCode">0</Data>
    <Data Name="BugcheckParameter1">0x0</Data>
    <Data Name="BugcheckParameter2">0x0</Data>
    <Data Name="BugcheckParameter3">0x0</Data>
    <Data Name="BugcheckParameter4">0x0</Data>
    <Data Name="SleepInProgress">0</Data>
    <Data Name="PowerButtonTimestamp">0</Data>
    <Data Name="BootAppStatus">0</Data>
    <Data Name="Checkpoint">0</Data>
    <Data Name="ConnectedStandbyInProgress">false</Data>
    <Data Name="SystemSleepTransitionsToOn">11</Data>
    <Data Name="CsEntryScenarioInstanceId">0</Data>
    <Data Name="BugcheckInfoFromEFI">true</Data>
  </EventData>
</Event>

 

Right before that

 

Log Name:      System
Source:        EventLog
Date:          8/3/2017 9:14:24 PM
Event ID:      6008
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Schuld
Description:
The previous system shutdown at 12:25:06 AM on ‎8/‎3/‎2017 was unexpected.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="EventLog" />
    <EventID Qualifiers="32768">6008</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2017-08-04T01:14:24.113732200Z" />
    <EventRecordID>7176</EventRecordID>
    <Channel>System</Channel>
    <Computer>Schuld</Computer>
    <Security />
  </System>
  <EventData>
    <Data>12:25:06 AM</Data>
    <Data>‎8/‎3/‎2017</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>443669</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Binary>E107080004000300000019000600BF02E107080004000300040019000600BF02307500003C000000010000003075000001000000983A00000100000000000000</Binary>
  </EventData>
</Event>

 

Before that

 

Log Name:      System
Source:        Microsoft-Windows-DistributedCOM
Date:          8/3/2017 8:31:33 PM
Event ID:      10016
Task Category: None
Level:         Error
Keywords:      Classic
User:          SYSTEM
Computer:      Schuld
Description:
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
{D63B10C5-BB46-4990-A94F-E40B9D520160}
 and APPID
{9CA88EE3-ACB7-47C8-AFC4-AB702511C276}
 to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
    <EventID Qualifiers="0">10016</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8080000000000000</Keywords>
    <TimeCreated SystemTime="2017-08-04T00:31:33.207062700Z" />
    <EventRecordID>7168</EventRecordID>
    <Correlation />
    <Execution ProcessID="1072" ThreadID="7232" />
    <Channel>System</Channel>
    <Computer>Schuld</Computer>
    <Security UserID="S-1-5-18" />
  </System>
  <EventData>
    <Data Name="param1">application-specific</Data>
    <Data Name="param2">Local</Data>
    <Data Name="param3">Activation</Data>
    <Data Name="param4">{D63B10C5-BB46-4990-A94F-E40B9D520160}</Data>
    <Data Name="param5">{9CA88EE3-ACB7-47C8-AFC4-AB702511C276}</Data>
    <Data Name="param6">NT AUTHORITY</Data>
    <Data Name="param7">SYSTEM</Data>
    <Data Name="param8">S-1-5-18</Data>
    <Data Name="param9">LocalHost (Using LRPC)</Data>
    <Data Name="param10">Unavailable</Data>
    <Data Name="param11">Unavailable</Data>
  </EventData>
</Event>

 

 

Share this post


Link to post
Share on other sites

The last event (8:31pm) was 45 mins before the next events which were generated by you rebooting your computer so can be ignored.

This is not easy to resolve. Your AMD processor is unusual for FSX but unlikely to be responsible. If you google "fsx freezes" you'll see multiple results and the cause could be a multitude of things.

Does it still freeze without RC4 running? When you install RC4 there are no changes made to core files or the Registry. It just installs VB runtime files plus its own files.

I can't really help I'm afraid. Try a process of elimination. Stop running Little Navmap. Try flying out of a stock airport. Try a default aircraft.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now