Sign in to follow this  
NickJZX

Stutter when P3D is main focus?

Recommended Posts

I seem to have a strange issue that I can't narrow down in regards to stutters. I have 3 monitors running, center one being for P3D and the rest are for external stuff, things like teampseak, ASP4, AH2 etc etc. For whatever reason when P3D is focused on (clicked into it) I get stutters, however when clicked out of it it all seems to go away. I'm curious if anyone has run into this issue at all before? Tried searching around google to no real avail except for some references to V2. Also, happens in most of my addon aircraft, wondering if maybe it's a sound issue but all my drivers are up to date at this time.

Specs:

i7-7700k 4.8GHZ

GTX1080

Z270A

16 GB DDR4 3200

500GB SSD (2 Samsungs striped)

 

This is a video of the issue in action, when the sound cuts out is when I go into another monitor;

Cheers guys!

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Update: tried multiple aircraft sound on and off and issue still present, can replicate even with chase plane when floating about the airport. Nvidia just released a new GPU driver so I may give that a go today. 

Share this post


Link to post

Are you using g-sync monitor?

I always have this issue. When P3d is focused, it loses a lot of frames and it gains more frames when it's unfocused ( From Nvidia forum, this is because g-sync ).

Gsync must be active for full screen only, and that doesn't completely eliminate the problem, I am still having this issue.

 

Share this post


Link to post

No G-sync monitor unfortunately.

However the issue is now fixed. This was a new install of windows and P3D, a majority of my settings were un-touched minus the basic prefer max performance stuff. After some digging I came across a suggestion by someone on another forum which seemed to solve a majority of the issue. Hopefully this can help you;

Go to System Properties > Advanced > Performance > Settings:

Under "Visual effects" make sure it's set to "Adjust for best performance". Turns out mine was set to Let windows choose which was causing havoc with P3D, after changing this the sim ended up running far smoother although still with some issue. If you go under advanced (under performance options) make sure it's set to "Adjust for best performance of: Programs".

 

The other step I took was to disable Nvidia Overlay. This solved the last chunk of my issue and now I can actually fly P3D with the same smoothness that's present when I was on a different task or monitor. Give those a shot and let me know!

  • Upvote 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this