airb0

Can't run the PMDG QOTSII installers

Recommended Posts

Hello

I'm having a weird problem with my PMDG installers. I just bought the 747-400 and -8 for P3D and when I try to run the installers, I get the prompt about running it as an administrator, but the nothing happens. I tried disabling Windows Defender, running the programs as an administrator, or in Windows compatibility mode, nothing worked. I ran them on another computer operating on Win10 and they ran without a single problem... That's a really weird issue. Anybody have a solution for this ? I also tried downloading them again and updating NET Framework. Nothing worked.

The weirdest thing is that it only happens with PMDG exes, I tried installing other add-ons and didn't have any problem.

Thanks for your help

Ali M'Sahi

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now