Deltaair1212

api.dll crash in P3Dv4.3

Recommended Posts

So for the past week I have been trying to track Down a certain CTD issue with v4.3 after I reinstalled Windows 10 on my computer and started fresh. The crash happens after the load screen finishes but the load screen indicator will go away and it’ll just be a black screen for about 10-15 seconds and then my sim will crash. And I will note the CTD doesn’t happen every single time that is what is making this tricky to hunt down. Windows has only logged two crashes out of the probably 20-30 crashes that have occurred since reinstalling P3Dv4.3 numerous times. The log says the culprit is api.dll. What that is, I haven’t a clue. It seems to be happening whenever I am in the Carenado S550. I haven’t been able to make the crash happen in any other aircraft. So I did several things just to see if it’ll help. I did a clean uninstall of P3D, and a clean reinstall. Didn’t work. I uninstalled every add-on I have, and reinstalled. Didn’t work. I did a clean uninstall, and reinstall of the latest NVIDIA driver. No luck. I uninstalled the S550, and reinstalled. Still didn’t help any. I even deleted the infamous Carenado Cmeteoxml.dll and that didn’t work. So I’m scratching my head as to what could be the cause of this. It doesn’t seem to be any other app, but the S550. The odd thing is, I have flown the S550 for a looooong time and have never had any CTD issues like this. I made sure I had v2 of the aircraft so it is compatible with P3Dv4.3. Does anyone know what could be the issue here? Thanks

Edited by Deltaair1212

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now