Jump to content

Sign in to follow this  
SDisco

Saitek FIP creates issues with the radio panel

Recommended Posts

Hi guys, hoping someone can tell me where I'm going wrong. Running FSX on WIN 10. Saitek Mulitfunctionc panel, Radio panel and switch panel all worked fine (using FSX default 747-400). But as soon as I try to get a FIP going it stops the ACT/STBY buttons on the radios working (all of them!). The buttons are fine. Problem still exists if I then disconnect the FIP. Tried uninstalling Logitech FSX plug in and using SPADnext but I get the same issue. Not a power issue as the FIP plugs directly into the MOBO, (besides the issue is still there if I disconnect it anyway). A full reinstall of FSX from scratch didn't sort it either.

Share this post


Link to post
Share on other sites

 Ok. I've sorted this out. Here's where I went wrong. I TRUSTED THE SAITEK DRIVERS! Spadnext works fine. What I didn't do was uninstall the Logitech FSX plugins, which I did after stopping the Saitek Direct output service in the services tab of the task manager. This also solved the issue I was also having with Multifunction panel as well.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    18%
    $4,710.00 of $25,000.00 Donate Now
×
×
  • Create New...