Ray Proudfoot

P3D v4.3 crashes on first load but fine thereafter

Recommended Posts

This is a weird problem that I can’t resolve. After booting up my new PC I launch P3D v4 and it will crash before the free flight window is displayed. I have to close the GoFlight program that controls my 7 GoFlight modules. ChasePlane closes itself.

But on second and subsequent launches it runs absolutely fine. I was installing 50+ scenery packages this week and after each one I loaded P3D and checked the airport looked okay. So this process has been well and truly hammered.

My EXE.XML contains two entries - one for ChasePlane and the other for the GoFlight executable.

Looking at Event Viewer there are two and sometimes three application error entries. The first will be ChasePlane, the second GoFlight and the last P3D. It’s always the dreaded ntdll.dll error.

These are not rare programs. Many people run these addons. But the weird thing is why it causes a crash on the first launch of the day and only the first launch.

The obvious answer is not to run these programs but I need them. It’s a real head-scratcher and one I’ve never had before. Anyone got any ideas?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now