Sign in to follow this  
vincentrouleau

Another Type Of Hang On Startup (ATHOS)

Recommended Posts

Again....

 

Yesterday, resuming a flight to Costa Rica, I startup P3D, and the splash screen goes away, and P3d process hangs at ~650Megs. word not allowed, what did I do this time.... 

This time I had not done any scenery changes in between the last session save.

So I proceed with the usual revert of old scenery.cfg ,no change.

Remove %APPDATA%/Local&Roaming/LM folders. no change.

Rename ProgramData/LM. Works ! ah...

swap exe.xml. Still hangs

swap dll.xml. Works! ah...

Turn RAASPRO.dll off. Works! ah....

 

Turns out, I did do a change. I installed Office 2019. replacing my Office 2016 installation, but without MS Access. That must have removed an MS access dll installed via PMDG 777 installation that installes the bundled FS2Crew RAAS stuff. There are references to problems with access database in FS2Crew forums. 

So again, another ~2 hours of my life trying to troubleshoot a P3D startup problem.

We need better logs during P3D startup to help investigate problems at startup. 

Has anobody ever used "ProcessMonitor" from the sysinternal miscrosoft tools to monitor file access during startup to troubleshoot P3D startup problems?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this