Sign in to follow this  
Guest tdragger

Backwards Compatibility with FS9 Add-on Scenery?

Recommended Posts

I know that with a new version of Flight Simulator, a new set of SDKs are released as well however, my biggest concern is whether or not add-on scenery developed for FS9 will work with FSX. I don't expect all scenery to be compatible. My area of concern is if scenery like terrain mesh, landclass, or VTP/LWM scenery will work with the new version.I have quite an extensive library of FSGenesis terrain along with USA Roads from Flight1.com that I don't just want to put on a shelf to collect dust once FSX is released.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,One of the bloggers said that they try to keep features for at least 2 more flight sim versions after it appears. Since VTP/LWM/landclass scenery showed up in FS2002, that suggests that it should still be in FSX. I don't know abou the terrain, since it showed up in FS2000. But I would doubt they would change it, since there hasn't been any real problem with it.We'll see...Hope this helps,--Tom GibsonCal Classic Propliner Page: http://www.calclassic.comFreeflight Design Shop: http://www.freeflightdesign.comDrop by! ___x_x_(")_x_x___

Share this post


Link to post
Share on other sites

Once again we will try not to break backward compatibility unless absolutely necessary.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this