Jump to content

j14

Pilot2ATC not hearing mic when using single headset (SOLVED)

Recommended Posts

I spent about 7 hours troubleshooting this problem, tried all solutions I read on the forums, and was at the point of banging my head against Honeycomb Alpha, but suddenly found a solution, so I want to share it in case someone has a similar problem.

Here’s a description of my original setup, with which I had issues.

 - Laptop (Dell G7) has a single headset jack (single 3.5 connector used for both mic and headphones), where I plugged external speakers. These speakers are set as default sound playback device.
- A HyperX AMP sound card is plugged into USB port. A HyperX Cloud Alpha headset is plugged into this USB card. The microphone is set as default recording device.
- X-Plane 11.50

 All other softwares were able to hear my microphone without a problem, but not Pilot2ATC. The latter was not hearing anything. I verified everything was correctly configured (PPT button lights green, aircraft radios on, microphone is set as default sound recording device, system language is set to “US English”, etc.), but no sound was going through. I went to “Grmr help” window, press “Practicing”, then press “PPT”, speak, and “Replay”, and there was no sound and no static. I tried plugging headset directly into 3.5 jack, tried another headset, no luck.

I did many hours of troubleshooting and finally identified the problem. I think it has to do with the fact that I use a headset as opposed to separate microphone and headphones. Apparently, with a combined headset (mic and headphones in one set), it DOES matter what is set as default playback device. So, even if your microphone is default recording, but the headset is not default playback, Pilot2ATC will not hear it. The screenshot below shows my original configuration that didn't work:

sound-settings-not-working.jpg

I then made my headset default playback device and all of a sudden everything started to work. Pilot2ATC hears my voice (make sure you go through training, or it will not recognize anything, especially if you, like me, are not a native English speaker).

sound-settings-working.jpg

It doesn’t matter if you are using a 3.5 jack or USB card. I tried plugging my headset into the 3.5 jack, and it was the same, microphone wouldn’t be heard in Pilot2ATC unless I made the headset default playback device.

PS: A little hint how to improve user experience. I prefer ATC chatter to come from headphones, and all other sounds from speakers, but X-Plane sends all sound output through a single channel. To achieve this, I made use of a known X-Plane bug. When you start X-Plane, it would use your default sound playback device for sound output, and will continue using it even if you change it while the simulator is running. Perfect! I go to sound settings, and change default playback device to speakers, then start X-Plane. Then, before I start Pilot2ATC, I would open sound settings once again, and set headset as default playback device. So now all engine and effect sounds are coming from speakers, but the chatter comes out of headphones, and microphone is working. I really hope X-Plane doesn’t fix this nice bug in future releases.

Edited by j14

Share this post


Link to post
Share on other sites

Also noticed that after computer was restarted, the headset microphone once again is not heard by Pilot2ATC until I reset it by switching default recording device to something else and back to the headset microphone.

So the full sequence of steps I need to do to make Pilot2ATC work after computer was started is the following:

1. Make speakers default playback device.
2. Start X-Plane (X-Plane is now using speakers for all engine and external effects and will continue to do so unless it's restarted).
3. Make headset headphones default playback device (required for Pilot2ATC to hear microphone and also required for ATC chatter to go through headphones as opposed to speakers).
4. Start Pilot2ATC.
5. Make computer built-in microphone default recording device.
6. Make headset microphone default recording device (for some reason, even if headset mic was default recording device, Pilot2ATC doesn't hear it until I reset it with steps 5 and 6).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    17%
    $4,475.00 of $25,000.00 Donate Now
×
×
  • Create New...