Sign in to follow this  
Guest flaflyer2

Ok, now I really have a problem

Recommended Posts

well, I have been lucky enough to enjoy fsx pretty well but recently when I am flying I am getting the sim1.dll error and shutdown. I know other posts have been made about this but there is not really a definitive answer and I realize there never may be one. Just to let you know it only happens when flying in europe. I have all the cloud9 x-class stuff, world of ai, and traffic 2005 which all run "fine" in any other part of the world. I tried taking x-class europe out but it didn't work. I also tried the repair option on the fsx install disc but that didn't work either. I haven't done anything major that may mess up my setup but all of a sudden there it is. It doesn't matter what time or season or location, eventually it all crashes around europe. I use a lot of ai obviously with no problems so it's not that either. What can I do, is there a specific file that I need to reinstall or is it a lost cause at this point. Yes, I know there are a lot of posts about this but most seem to be about fs2004 and fsx is much different as you all know by now. Also I know the first thought will be something like "don't fly around Europe" funny as that is, I think this a serious issue at least to me. As always I am thankful for anyone that can help.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have had a couple of sim1.dll crashes in Europe too. I think that this has sth to do wit the amount of AI tfc. Try to lower you ai-percent a little, that helped me.Petteri PulkkinenVihti, Finland

Share this post


Link to post
Share on other sites

It's possible that a particular AI A/C (or maybe just a specific livery) is only being used when you are in Europe (is it always near the same airport(s) ) vs other locations. Generally an error in Sim1.DLL is caused by an aircraft (either user or AI) doing something "wrong".

Share this post


Link to post
Share on other sites

Thank you for the help. I am going to try to reduce the ai tommorow and see what happens. After all 99.9% ai shouldn't make too much of a visual difference (hahaha). It doesn't always happen around the same airport but I have noticed it more in the "middle" part of Europe. For example, Amsterdam,Frankfurt,Zurich and others around that area which has a lot of ai traffic so finding an offending ai will be a very long process. It's a shame because those are great airports for spotting and ai and I used to fly them a lot until this started happening. I'm also thankful that this is not a fatal problem and maybe with time I can fix it.

Share this post


Link to post
Share on other sites

Well did you have the problem before you installed the add-ons? I know it sounds obvious, but if not, then one of them is the issue--why it would just be a problem in Europe, I have no idea.My only problem with FSX is the "memory leak" e.g. after about 7-8 hours of flying with everythihg on max, the computer will "use all available memory." That can be fixed by dialing down scenery, I guess, but I want it all :(

Share this post


Link to post
Share on other sites

Well, in this case "near" an airport would mean within the AI radius of a specific airport (and sorry, I don't remember what the AI radius is). Another thing to try would be the traffic toolbox tool from the SDK and see if you can spot a new AI aircraft being added right before the Sim1.Dll error pops up.

Share this post


Link to post
Share on other sites

well ok, I tried several things. First, I lowered my ai settings but it didn't work. I also tried removing cloud9 x-class europe and reinstalling it but that also didn't help. I think it may be a specific livery in europe causing this like mentioned before. I have traffic 2005 and every world of ai package installed and it is not easy trying to find it. What I have done is use traffic 2005 for most of my traffic and then as each week a new world of ai package is released, I take that one out of traffic 2005. I am hoping for either a new world of ai package replacing the livery that is causing the problem or some way of checking to see if I have a bad livery but how can that be done?. With so many liveries it would be a very long process. I think that I have a better chance for the first solution. I can also delete traffic 2005 when traffic x is released, oh decisions, decisions. Thanks evryone.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this