Sign in to follow this  
Cruachan

Stutters? Try this.....

Recommended Posts

Hi,I felt a little hesitant about posting this as it is all too easy to get carried away when you think you may have stumbled on something that might prove to be helpful. Anyway, in for a penny in for a pound, here goes:When you first install FSX you may have noticed that the TEXTURE_BANDWIDTH_MULT defaults, as does mine, to a value of '40'. On slower mid->low range systems this value could be '30'. Many have advocated increasing this figure to '400' to improve texture loading, but I have found that this is not helpful on my rig as shown by increased levels of stuttering and surging making the sim virtually unflyable, and this is especially so when the frame rate target is set to unlimited. I think ACES prefer the value of 40.Perhaps what I am about to suggest might seem heretical, but I invite you to give it a shot and see how you get on.If your value is currently 40 or higher and you are seeing a lot of stuttering, try the effect of reducing TEXTURE_BANDWIDTH_MULT to 30. I was pleasantly surprised to see a much smoother sim and the ground textures were still updating quite nicely. I'm not saying that stuttering is a thing of the past, but, when present, I would say it is now acceptable. I tried lower values, even down to zero, but this introduced texture blurring.Obviously more testing is needed. All my initial testing is done at Friday Harbor with my frame rate locked at 20 which seems to be about right for my rig. With photoscenery I can raise this to 30 fps. The only other tweak used in fsx.CFG is Poolsize=6000000 (I have a 512MB GPU).I am using the GenReloaded Building Textures: fsxbdgs.zip and TreeX (Quality textures) treex_v2.1.zip with the following settings:TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=2500TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=3000Certainly many other factors are likely to be involved and you should be prepared to play with your sliders (yet again!) to establish the best balance. I've attached my current fsx.CFG file which should act as a general guide, but these settings are certainly not set in stone. Many of you can chose more aggressive settings while others will have to be more conservative.Ignore the 'ProcSpeed' and 'PerfBucket' entries. Changing them after fsx.CFG is first created will do nothing, so don't bother.http://forums.avsim.net/user_files/173477.zipIf experience to date is anything to go by we can be sure that any tweak will have different effects on different systems, so no guarantees. Please post your results because, good or bad, they will all be valuable.MikeASRock 939Dual-SATA2, AMD Athlon 64X2 4800+ (2400MHz)(Toledo), 2GB Crucial PC3200 DDR400 Ram 3-3-3-8 (2T)(Dual Channel), (PCI-E)Sapphire ATI Radeon X1950 Pro 512MB (Catalyst 7.1 WHQL), SB Audigy2 ZS Platinum (Drivers version 5.12.0001.1196 WHQL), Windows XP Home Edition (SP2), DirectX 9.0c (with 06/2007 update)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Surprised nobody has tried this, or, if you have, perhaps didn't think it worth responding. Fair enough, it's very possible that this effect is very system specific and can't be reproduced on other rigs. It would be interesting to know that this was in fact true, however.You don't need to change anything else in FSX. I have to assume that if you're still flying the sim you have reached that tweaking point where performance is now more or less acceptable. That's fine. All I'm suggesting is that you try this one more tweak and see whether it makes any noticeable difference at all.Maybe you could combine it with using my stutter test flight situation file - Try a 'before' and 'after' test.For those that have not already seen it in my other thread ( http://forums.avsim.net/dcboard.php?az=sho...d=401160&page=3 ) here is a brief extract:"I would like you all to conduct a little experiment using the flight situation files which you can download using this link:http://download.xdrive.com/s/437081836rTaw...NP&partner=plusJust unzip them into your My DocumentsFlight Simulator X Files folder and on the 'FREE FLIGHT' screen select 'Load' and then 'Mike_Stutter_Test'.You should find yourself in flight watching the Trike from SPOT view at roughly 1400ft. The Trike is moving right to left. Just let it continue through several 360's or adjust the bank yourself."I may be wrong, but it seems to me that that there is a correlation between the stuttering phenomenon and available bandwidth for processing textures at any instant of time. This would in some arcane way explain end user experiences based on the huge variance in slider settings, CPU/GPU/MoBo/Memory/Drivers in use, locking or unlocking of frame rates and whether or not photoreal scenery tiles are being loaded and displayed (I get very good results with photoreal scenery and also, to a lesser extent, TileProxy once the cache of tiles in the area folder being flown has matured).The TEXTURE_BANDWIDTH_MULT tweak was used widely in FS9 as it was shown to influence the rate at which textures were being loaded. Even then we had to be careful as high values could cause stuttering on some systems, whereas others saw more favourable results. Still, it was a very useful tuning tool to be used as part of our efforts to encourage the sim to run smoothly across a wide range of hardware. In FSX the situation appears to be somewhat different and often it seems that the value of TEXTURE_BANDWIDTH_MULT is better left at the default value which appears when fsx.CFG is first created or when the sim is 'Reset'.As I see it, it's all a matter of finding an acceptable balance. So far, reducing this value to '30' on my system appears to be having a positive effect. However, this is limited in that I can't reduce it much further without a degradation in visual quality creeping in. I have a dual core CPU and 512MB video ram so these could be factors influencing the perceived outcome. It would be interesting to find out whether this effect is seen by other multi-core users post SP1 and also whether single cores also benefit.Anyway, I just thought I would throw it into the mix of ideas and see what comes out of it, if anything.Mike

Share this post


Link to post
Share on other sites

On my system I had to remove the bufferpool entry to eliminate stutters. Didn't work for me with any value.==Marten:Weber==P-D920 oc3.64MHz 2GB RAM WinXP ATI X1900+1024MB 2xSATA250 2xVIEWSONIC 19"Best AI available today: www.world-of-ai.com

Share this post


Link to post
Share on other sites

Copy from Phil Taylor's Blog of June 3rd:"From Rafael Cintron, part of the FS Graphics and Terrain team, comes this description:The TEXTURE_BANDWIDTH_MULT option in the Graphics section is the target frame rate use for calculating texture bandwidth. The higher you set this value the more textures we will allocate and copy per frame to the graphics card. The lower you set this value, the less we will allocate and copy up to a minimum limit. As an example, the default rate in the

Share this post


Link to post
Share on other sites

Hi Martin,Thanks for responding - I was starting to feel a tad lonely out there..LOL!"On my system I had to remove the bufferpool entry to eliminate stutters."Eliminate? Really? Wow, if only the solution was so simple!In actual fact, of course, while you have removed the entry the Poolsize defaults to the value 4000000. Mike

Share this post


Link to post
Share on other sites

Thanks for the info. I'll give it a go.Regards,jack

Share this post


Link to post
Share on other sites

>Hi,>>I felt a little hesitant about posting this as it is all too>easy to get carried away when you think you may have stumbled>on something that might prove to be helpful. Anyway, in for a>penny in for a pound, here goes:>>When you first install FSX you may have noticed that the>TEXTURE_BANDWIDTH_MULT defaults, as does mine, to a>value of '40'. On slower mid->low range systems this value>could be '30'. Many have advocated increasing this figure to>'400' to improve texture loading, but I have found that this>is not helpful on my rig as shown by increased levels of>stuttering and surging making the sim virtually unflyable, and>this is especially so when the frame rate target is set to>unlimited. I think ACES prefer the value of 40.>>Perhaps what I am about to suggest might seem heretical, but I>invite you to give it a shot and see how you get on.>>If your value is currently 40 or higher and you are seeing a>lot of stuttering, try the effect of reducing>TEXTURE_BANDWIDTH_MULT to 30. I was pleasantly>surprised to see a much smoother sim and the ground textures>were still updating quite nicely. I'm not saying that>stuttering is a thing of the past, but, when present, I would>say it is now acceptable. I tried lower values, even down to>zero, but this introduced texture blurring.>>Obviously more testing is needed. All my initial testing is>done at Friday Harbor with my frame rate locked at 20>which seems to be about right for my rig. With photoscenery I>can raise this to 30 fps. The only other tweak used in fsx.CFG>is Poolsize=6000000 (I have a 512MB GPU).>>I am using the GenReloaded Building Textures:>fsxbdgs.zip and TreeX (Quality textures)>treex_v2.1.zip with the following settings:>TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=2500>TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=3000>>Certainly many other factors are likely to be involved and you>should be prepared to play with your sliders (yet again!) to>establish the best balance. I've attached my current>fsx.CFG file which should act as a general guide, but>these settings are certainly not set in stone. Many of you can>chose more aggressive settings while others will have to be>more conservative.>>Ignore the 'ProcSpeed' and 'PerfBucket' entries. Changing them>after fsx.CFG is first created will do nothing, so don't>bother.>>http://forums.avsim.net/user_files/173477.zip>>If experience to date is anything to go by we can be sure that>any tweak will have different effects on different systems, so>no guarantees. >>Please post your results because, good or bad, they will all>be valuable.>>Mike>>ASRock 939Dual-SATA2, AMD Athlon 64X2 4800+ (2400MHz)(Toledo),>2GB Crucial PC3200 DDR400 Ram 3-3-3-8 (2T)(Dual Channel),>(PCI-E)Sapphire ATI Radeon X1950 Pro 512MB (Catalyst 7.1>WHQL), SB Audigy2 ZS Platinum (Drivers version 5.12.0001.1196>WHQL), Windows XP Home Edition (SP2), DirectX 9.0c (with>06/2007 update)>Mike,Thanks again for the useful info. I reduced my BANDWIDTH_MULTI to 20 and the Stutters in Spot & Wing view are almost eliminated.Many thanks.jack

Share this post


Link to post
Share on other sites

You're welcome, Jack. Glad it helped.I realize this will probably only help a few, but nearly a 1000 views and only 2 replies!? Deary me :(Jack found a lower figure helped and this illustrates the importance of being prepared to experiment and give it a go. I tried dropping to '20' but it didn't help my case. Others may also wish to try lower values or even try reducing in steps of, say, '2' from '40' with the aim of finding that sweet spot.You'll never know if you don't give it a shot.Mike

Share this post


Link to post
Share on other sites

I'm gonna give it a shot asap... probably this weekend... will let you know

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this