Sign in to follow this  
FlyingsCool

Problem with screen redraws

Recommended Posts

I'm having a couple of problems with my display. Whenever I quickly move the nose above the horizon, text is written on the display, sometimes when I first press the zoom view key, and sometimes seemingly randomly the screen flashes black and white first with lights and other effects large and square, then the squares gain colors, then the screen redraws itself.Also, whenever I turn on or turn off a 2D panel, the whole screen goes black, and then gets redrawn.All of this display pausing is very annoying as it disrupts the flight and pauses the system.I don't know if this is a hardware or software problem, so I am posting it here.I have a Dell D810 laptop 1.86 GHz Pentium M/ATI X300 64 MB graphics/2 GB memory at 1920 x 1200 x 32 (native screen resolution). I'm locking at 15 fps, and generally get that in most areas.The problem is not related to Tooltips. I get the same reaction with them either on or off.FSX settings are:Bilinear FilteringAnti-Aliasing: onGround and Plane Shadows: offGlobal Texture resolution: Very highLens flare: offLight Bloom: offAdvanced Animations: onLOD Radius: SmallMesh Complexity: 80Mesh Resolution: 76 mTexture Resolution: 2 mWater effects: none - 1.x highScenery complexity: DenseAutogen: offSpecial effects detail: HighCloud Draw Distanc: 60 miSimple CloudsTraffic: offRelevent config file options are:ForceFullScreenVSync=FalseForceVSync=FalseChangeTime=0.000000TransitionTime=0.000000SKINNED_ANIMATIONS=1TEXTURE_BANDWIDTH_MULT=40UPPER_FRAMERATE_LIMIT=15WideViewAspect=TrueMipBias=6Poolsize=5000000FIBER_FRAME_TIME_FRACTION=.33SHADER_CACHE_PRIMED=1693428480TEXTURE_MAX_LOAD=1024NUM_LIGHTS=8AIRCRAFT_SHADOWS=0AIRCRAFT_REFLECTIONS=1COCKPIT_HIGH_LOD=1LANDING_LIGHTS=1AC_SELF_SHADOW=0EFFECTS_QUALITY=2GROUND_SHADOWS=0TEXTURE_QUALITY=3IMAGE_QUALITY=0See_Self=1Text_Scroll=1LENSFLARE=0DAWN_DUSK_SMOOTHING=1IMAGE_COMPLEXITY=3SmallPartRejectRadius=4LOD_RADIUS=2.500000MESH_COMPLEXITY=80MESH_RESOLUTION=19TEXTURE_RESOLUTION=24AUTOGEN_DENSITY=0DETAIL_TEXTURE=0WATER_EFFECTS=0TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=4500TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=3000SWAP_WAIT_TIMEOUT=15Given it's a laptop, I'm using the latest drivers available on the Dell website for the laptop.ATI Display BIOS version: 008.017.192.059ATI Display BIOS Date: 2005/03/15ATI Display Driver versions are:2D Version: 6.14.10.6568Display Driver Version 8.131.1.2-050706a-02030C-DellControl Panel Version 6.14.10.5154For DirectX I've installed both the June and August DX runtimes (how do you tell if they are installed correctly?). Several of the dx files are dated 8/19/2007 in dxdiag.On the Display Adapter:VPU recover is turned offPowerplay is turned offDirect3D page is set to Application preference for both AA and AF, with texture preference and mipmap detail level sliders set to performance and wait for vertical sync always offWMV Acceleration is onRe-activate all warning messages: offEnable ATI taskbar icon application: offDisable quick resolution feature: offReduce DVI frequency on High-resolution displays: offAlternate DVI operational mode: offMy frame rates are fine as setup above. But the fairly constant total redraws of the screen are very annoying. Any suggestions on fsx.cfg settings or changes to my display card setup?********************Should I add any other options to fsx.cfg or change any of the ones there? Is there anything else I can change on the display adapter?Is there anything I can do? I realize I'm pretty lacking on display memory. But why does it keep reloading the screen once it's there. That's why I split it up into what seems like two problems. The black and white then redraw is related to when characters are drawn on the graphics screen (like brake sign, etc.), but I also get the same problem when the outside screen changes relatively quickly. Just pulling the nose up causes a problem as the nose goes past the horizon.So, to me, the problem seems to be related to overlays, except why it changes even when I'm doing acrobatic maneuvers like pulling my nose above the horizon or press the zoom key has me totally baffled. These two operations don't have any change in overlay as far as I can see.The problem happens all the time when moving the nose above the horizon (like when I'm doing a loop, normal climbs aren't a problem). It doesn't happen all the time when zooming, but does most of the time on first press. Once zooming it is fine, and if I press zoom again in succession, it is fine, no redraw.Thanks!Thomas[a href=http://www.flyingscool.com] http://www.flyingscool.com/images/Signature.jpg [/a]I like using VC's :-)N15802 KASH '73 Piper Cherokee Challenger 180

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this