Sign in to follow this  
Guest TonyPiech

Vista SP1 and OOMs

Recommended Posts

Hopefully when Vista SP1 arrives, my OOM problems will disappear. I realize that some beta versions are available currently, but I'm just not a "computer geek". To bad that you may have to become one to run FSX and addons sucessfully. So I'm hoping that Vista SP1 will do the job, as far as OOMs are concerned.http://blog.wired.com/monkeybites/2008/01/...-service-p.html

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

There is already a Vista patch for the "shadow graphics memory" bug in Vista. I blogged about this last August.And the FSX-SP2 executable is marked as /3G aware so if you change your OS boot to recognize that the app and OS will cooperate in extending the address space.I do not know what else Vista SP1 adds to the equation except rolling up all the individual patches like the "shadow graphics memory" one.

Share this post


Link to post
Share on other sites

Phil, thanks for the quick response, as you can see by my post, I'm not as computer literate as many who may run FSX. I generally assume when I buy a product like FSX and some addons that they should work comfortably without me sorta going "under the hood" and tweaking a bunch of program files to get the product to work.I'm running FSX SP2 in DX10 mode on a fairly up-to-date computer, Belarc says that I have: 3070 Megabytes Installed MemorySlot 'DIMM_1' has 1024 MB (serial number 081ABD10)Slot 'DIMM_3' has 1024 MB (serial number 081A1B12)Slot 'DIMM_2' has 1024 MB (serial number 081ABE15)Slot 'DIMM_4' has 1024 MB (serial number 0819C412)The math doesn't seem to add up when I have a total of 4,096 Megabytes but only 3,070 Megabytes of "Installed Memory", but what do I know??I'm not sure what you're saying in your post about FSX-SP2 executable is marked as /3G aware so if I change my OS boot to recognize that the app and OS will cooperate in extending the address space. I may have a degree of computer ignorance here, I boot my computer by tuning it on and VISTA Ultimate does its thing and I open FSX SP2 by clicking on the icon and it opens. Should I be using a different boot methodology to get my OS to recognize and use all of my memory more efficiently? My records (per Belarc) indicate that KB940105, as mentioned in your August Blog, has been installed on my computer on 12/25/07. So I'm not sure what more I can change for my OS boot to extend the address space. Any additional words of advice that you can provide this computer challenged novice will be greatly appreciated.

Share this post


Link to post
Share on other sites

Ok, so you have the patch from here.http://blogs.msdn.com/ptaylor/archive/2007...other-ship.aspxGreat, that is step 1. Step 2 is giving FSX some more room. I talk to how you can tweak the OS to let FSX-SP2 have a bit more breathing room, read here:http://blogs.msdn.com/ptaylor/archive/2007...ress-space.aspxWith that, your FSX process now has more room to run in. With a lot of add-ons and with high settings, FSX starts to push the normal process address space limit of 2G. The /3G switch is designed for exactly this case.Lastly, I try to explain the memory reporting anomaly in Windows, read here:http://blogs.msdn.com/ptaylor/archive/2008...-is-in-use.aspxhth

Share this post


Link to post
Share on other sites

Phil, thanks again for the abve response and additional guidance. I've dowloaded and installed the PE editor- CFF Explorer and opened the fsx.exe within CFF, with that file opened went to the NT Header/File Header and clicked File Header, found the button marked "click-here" and a box opened, saw a check mark already marked at the "App can handle> 2gb adressest" . Since the box was already checked for App can handle> 2gb adressest, I did not save the fsx.exe but exited from the program. Is that OK?I then opened the command prompt, right clicking & selecting "run as administrator", believe a line saying sysytem 32 appeared, I then typed "bcdedit /set IncreaseUserVA 3072" (without the quotes). After hitting "enter" a line appeared saying my action was successful.Can you confirm that what I did is "OK". I'm not sure, because I didn't overwrite the fsx.exe in CFF Explorer because the App can handle> 2 gb adressest box was already checked. Is there a way that I can check that the bcdedit /set IncreaseUserVA 3072 was correctly applied?

Share this post


Link to post
Share on other sites

Correct the FSX.exe is already marked with SP2 and you need do nothing.Yes, you should set userva. I recommend 2560 as a start, and if that doesnt work increase it in increments of 128. 3072 leaves mighty slim pickings for the OS itself.

Share this post


Link to post
Share on other sites

Phil, thanks for helping this computer novice, I'm assuming to reset/change the userva, I should open the command prompt, right clicking & selecting "run as administrator"; then type bcdedit /set IncreaseUserVA 2560 or should it be bcdedit DecreaseUserVA 2056 since I changed it to 3072 previously? Also, is there a way to view what my userva actually is, before I take action to change it?

Share this post


Link to post
Share on other sites

I would set IncreaseUserVA 2560, and ignore what you did before.If you see the working set in the Task Monitor or other tools go over 2G you know its working. Short of that, no I do not know a way to monitor it.

Share this post


Link to post
Share on other sites

Thanks for your help Phil, got the userva reset to 2560, hopefully no more OOMs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this