Sign in to follow this  
Guest Stefanosg

Shading in v2

Recommended Posts

Is there any solution to the streaky appearance pictured below. I am converting my DHC-2 so that it can use refl texts. The problem existed in v1, but I thought this was something that could be fixed in v2. Any thoughts on how to fix this?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Steve,remove the polygon smoothing on your control surfaces. If they are only 3 or 4 polys (not counting the ends) you won't notice anything in FS but the wierd shading will go away. also, cut the fill in poly in the surface gap into a seperate part and that will help some. Also look for polys in the wing (or any other part) that has been put in buy the program. Sometime if you add a cross section it ads in a poly on that cross section that can ad in a wierd shadow.Brian

Share this post


Link to post
Share on other sites

Basically, split your 4 points (or more) polygones in two or more triangular polygones (try have them forming a convexe shape) and your problem is to be solved and you dunnot need to remove the smoothing.

Share this post


Link to post
Share on other sites

Hi Brian,I had the same thing on my P39. However, because I was having so much difficulty with the animation I ended up re-joining all the surfaces and turning off the smoothing. Once the texture was applied the lack of smoothing was not noticeable.John Woodward

Share this post


Link to post
Share on other sites

New feature in FSDS 2.0Select the polygons on the front of the control surface and go to Edit > Polygon Properties. Set the smoothing group for those polys to 1. This will turn off polygon smoothing for only those polys and leave it on for the rest. This eliminates the need for splitting parts and turning off or on ALL smoothing. Davewww.daviator.com

Share this post


Link to post
Share on other sites

Thanks for all the help guys. Removing the polygon smoothing from the control surfaces had the best results. However, I found the real problem. Seems I had a closed polygon located within the wing located between the wing root and the inside edge of the flaps. Once I removed these, the irregular shading went too.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this