Sign in to follow this  
Guest

Shading

Recommended Posts

I am having a problem with the aft section of my fuselage matching the forward section. As you can see from the pic, there is a noticeable difference in the shading between the two. The colors(materials) are the same and I tried rejoining the two, but to no avail. Any suggestions to fix this problem?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Did you weld the Verts at the point of the rejoin?This is usually the problem..Al

Share this post


Link to post
Share on other sites

Sounds like a GMAX answer. Sorry, I should have mentioned this was done with FSDSv2

Share this post


Link to post
Share on other sites

Hi Steven,Regardless of tool, all faces have edges and if edges are turned differently, it could throw off the smoothing/shading.There is an excellent tutorial done (for gmax) by Finn Neuik that talks of this issue. You can find it here:http://supadetail.gmaxsupport.com/Hope this helps.Milton

Share this post


Link to post
Share on other sites

>I am having a problem with the aft section of my fuselage >matching the forward section. As you can see from the pic, >there is a noticeable difference in the shading between the >two. It seems that you made the fuselage from two pieces, this is a good method but it leaves a junction. Even if you join the pieces (pressing J) the junction rests because each point on it is not a single one but two copies - one from the right piece and one from the left one. To eliminate the junction you need to delete the redundant points. There is a command for this ("Snap to scale") but it doesn't work correctly - it eliminates too many points and the part changes dramatically the shape (note to FSDS developpers: this is a BIG BUG).Here is how to eliminate the junction manually :1. Select one of these parts. Select all the points on the junction;2. Delete them. This will cut off all the polygons that contain these points. You'll need to recreate them manually.3. Select both parts. Join them (press J)4. Now starts a long job: create all the missing polygons one by one. The junction will dissapear. Magic5. To finish, press F2 to show up the part's properties. Check the checkbox "set material" in order new polys be of the same material as the whole part. This works very well but takes a lot of time.Hope this helpsDimitri

Share this post


Link to post
Share on other sites

Samdim wrote:>("Snap to scale") but it doesn't work correctly - >it eliminates too many points and the part changes >dramatically the shape (note to FSDS developpers: this is a >BIG BUG).True, but there is also a workaround for this issue. All you have to do is set the scale in Porject Properties. You can find this option under File -> Project Properties and then the right top corner "Scale". Set this scale to 0.002. With this setting the parts won't deform. Caution: This setting is not for scaling the aircraft or other objects. This setting merely scales the virtual grid along which the points are aligned. There was a huge confusion with the name of this setting.

Share this post


Link to post
Share on other sites

O.K. I will try it. If it works, it would save a LOT of time! Thanx

Share this post


Link to post
Share on other sites

Another thought, from a gmax perspective, anyway: what about smoothing groups? Just make sure both sides of the junction are in the same group, and that boundary should disappear as well. I'm sure there must be some control over smoothing groups in FSDS2 as well.Matt

Share this post


Link to post
Share on other sites

FSDS2 has proudly announced a support for smoothing groups but in fact there is no one. The only thing (but I agree it is really useful and cool) is that you can now smoothen or not each polygon personally (there is a checkbox and a field for this in "Polygon properties" dialog).

Share this post


Link to post
Share on other sites

Wow, thanks for all the suggestions guys. I did consider the rejoining you mentioned. Eliminating the redundant points and recreating the poly's by hand. I am going to try the scaling thing first and see how that works.

Share this post


Link to post
Share on other sites

From the picture, it does not look as bad as it might seem. In FSDS2, if you try to smooth out two adjacent parts (2 parts of a fuselage, or a wing and a flap for example...), it results in some funny lighting effects since the curves of the model won't match up.When I build the fuselage, sometimes I split it into several 2 or 3 parts. The trick is to wait until you are completely finished making the fueslage before doing this. That way, each part will keep its original shape and match up properly.In your case, the parts might match up close enough already. It might not look perfect while in FSDS2, but once you texture it and load it into FS2K2 it might look fine. FSDS2 does not necessarily display the model exactly how FS2K2 will. I'm building a plane right now that has a similar effect to the one in your picture - my fueslage is all one piece. Once I got it finished and into FS2K2 the "bend" disappeared.- Martin

Share this post


Link to post
Share on other sites

Looks like we are busy with the same plane..that's a DHC2 right..?

Share this post


Link to post
Share on other sites

Its actually already done. Its the fuselage from my DHC-2 that I finished back in December using v1. I am using v2 to update it and fix some bugs I have found along the way. The last of which is this shading issue.

Share this post


Link to post
Share on other sites

I originally finished it using FSDSv1 and released it. When v2 came out I started updating and fixing the model.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this