Sign in to follow this  
Guest

Textures not showing in GMAX.

Recommended Posts

When I apply any bitmap to a part of my model in gmax, it doesn't appear in the viewport. It fill the part in as solid gray. I have tried all moded in the viewports (shaded/faceted/smooth etc.) but none work.. This applies to any part of my model. I can see the texture OK in the material editor, the texture is a standard 256x256 size. I just cant work out why I cant see the damn thing. ( I even tried changing the driver setting in preferences to copy with 512 textures).. Any ideas??

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Bill,thanks for the tip but it still doesnt work.. I have applied a UVW modifier and still nothing.. this is really fraustrating..Any more ideas??Mark

Share this post


Link to post
Share on other sites

>Bill,>thanks for the tip but it still doesnt work.. I have applied a>UVW modifier and still nothing.. this is really>fraustrating..Mark, there ae too many things that it might be, that we could go on like this for days! :) How about outlining step by step what you are doing, then perhaps we'll be able to pinpoint the exact spot where it's going awry... :)BillAVSIM OmbudsmanFounder and Director,Creative Recycling of Aircraft Partshttp://catholic-hymns.com/frbill/FS2002/images/fartslogo.jpg

Share this post


Link to post
Share on other sites

OK Bill, I'll try to remember the steps I have taken..1. Created a shape (dashboard)2. Extruded shape to make it a solid3. Add a UVW modifier to solid.4. Created Texture in PSP. Saved as standard bitmap (as per your earlier instruction)5. Created material in GMAX, can see the bitmap on the sphere that is in the material creator window.6. Selected Object.7. Clicked Apply, the solid changes colour to grey, but does not display texture in viewport.8. Got really angry9. Tryed playing around with the UVW modifier to see if it was scaled incorrectly.10. Gave up11. Go for a cigarette.12. Post on here hoping someone has a solution.13. await answer.Hope that helps :-)

Share this post


Link to post
Share on other sites

I just happen to be working on a really, really simple project to assist Louis Sinclair (programmer for FSDS2) to determine why his program cannot use my GMax-SDK Approved technique for VC gauge backlighting... so I'm in the process of creating/texturing a simple object anyway... :) It's a single planar object for gauge projection panel...1) Create a planar object (rectangle, square, etc.)2) Convert to Editable Mesh, select Polygon Mode, use mouse to select all polys.3) Tick off "Show Normals," then look at the Left Window to see which way the blue lines point! They should be pointing towards the back of the a/c if you are making a panel. If they face the wrong way (forwards), either rotate the part 180 degrees, or... scroll down the rollout until you find the "Flip Normals" button and click on it. Voila! Normals face the right way... :)4) If Normals are OK, then untick the "Show Normals" box, click on the Edit Mesh line, click on the drop down list and select UVM Mapping.5) You should now have an orange box around your entire object.6) Click on the Material Editor to open the window, click on New, Standard, OK.7) Click the + button next to Maps to open the dialoge.8) Click on Diffuse Color, double-click on Bitmap, browse to your texture.9) Highlight your texture, click on OK to return to the Material Editor.10) Click the Apply button, notice that it doesn't do anything except apply a background color to your part! :(11) Click on the FILENAME at the bottom of the ME Window, hold mouse button, drag to your panel and DROP THE TEXTURE on it... :)The texture should now show on your object in the Perspective panel. (Hint: right-click on the name of the GMax View Window (such as "Front"), select "Smooth + Hilights" to see your texture on the object.I hope this will help you out... but, be forewarned it isn't always this easy! :)Now I have to go smoke a cigarette and fix dinner!BillAVSIM OmbudsmanFounder and Director,Creative Recycling of Aircraft Partshttp://catholic-hymns.com/frbill/FS2002/images/fartslogo.jpg

Share this post


Link to post
Share on other sites

Bill,as always, yer a blimmin' genius...Thanks mate.. works a treat.Mark

Share this post


Link to post
Share on other sites

EDIT: I see you fixed it as soon as i posted... goodjoe

Share this post


Link to post
Share on other sites

Actually, to show your textures in the viewport you need to do something else. There is a small button looking like a checkerboard, blue and white, in your material window. Make sure you punch that one. Should make your texture appear in the viewport.Udo.:-wavePS.Bill, I may need some help from you with the panel backlighting thingy.

Share this post


Link to post
Share on other sites

Also on a side note, Gmax does also allow 24 bit bmp's aswell as tga and jpg.Udo.:-wave

Share this post


Link to post
Share on other sites

It is also very helpful sometimes to turn off the rendering of textures in the viewport, especially when doing detailed close work.You can do this by going to Customize/Viewport Configuration/Viewport Rendering Options and click Disable Textures.The textures reappear by unchecking that option.Milton

Share this post


Link to post
Share on other sites

>PS.>>Bill, I may need some help from you with the panel>backlighting thingy.Having once again been laid off from my $job (yes, I have to $work just like everyone else!), I'll dedicate Friday to writing a tutorial on panel backlighting and geting it posted. Of course, I'll always answer direct questions... :)On a related note, I'm working closely with Louis Sinclair to help him get this technique working in FSDS2 as well. As some may have gathered by now, I'm sort of a "self-appointed zealot" for improved VC panel lighting! :)BillAVSIM OmbudsmanFounder and Director,Creative Recycling of Aircraft Partshttp://catholic-hymns.com/frbill/FS2002/images/fartslogo.jpg

Share this post


Link to post
Share on other sites

Hi AllSince we're on the subject of textures not displaying in GMAX I have an unusual complaint.In Direct3D I can see all texture maps I apply to the mesh. Manipulation in Direct3D is terrible so I use open GL. However I cannot see any texture maps in Open GL. The components and coloured differently assuring me there is a material there but no textures. Been like this for over 5 months. It is a driver issue; Open GL v1.4 is the open Gl driver in viewport config menu. I got a new 64mb DDR PNY Geforce 4 Ti last week with new drivers - no change. I upgraded to the latest Nvidia detonator 4.35 drivers - no change.I don't smoke but it might get me started.I want to know if anyone has experience the same and been able to tick a menu box or make a selection in GMAX that might help me.Failing that can I roll back to a different openGL driver? Have I a registry problem? Is the a line in the GMAX ini file or CFG file I can insert or change?So many questions so few answers.....regards Paul

Share this post


Link to post
Share on other sites

Hi Paul,Wish I could help you with this one. From what I know the textures should show up, whether using Direct3D or Opengl. For me Opengl renders faster, so I stick with that one. If the only thing you did was switch between D3d and opengl, it should be fine. Maybe someone else can shed some light here.............And Bill,Thanks in advance for the tutorial. Could you maybe also include How you added the compass gauge to the seperate housing. I applied a dummy 128x128 texture, but nothing is showing up !!Greetz,Udo. :-wave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this