Sign in to follow this  
Guest

makemdl error on export

Recommended Posts

I'm getting the path error when I try to export a building. I've exported the smae building with no modification before, but now it just won't work. Here is the erro log:Running modelStart! (C:WINDOWSDesktoptermc)Loading X C:WINDOWSDesktoptermc...Processing...Model units are 2.00 units/meterSorting by Material...Optimize Parts...Welding...Generate BGL...Done!WARNING: radius is too big for crash dataGenerate crash tree 1 (6128 bytes) Assembling: C:WINDOWSDesktoptermc.azmC:WINDOWSDesktoptermc.asm(30) : error A2071: initializer magnitude too large for specified size SCALE_AGL(6): Macro Called From C:WINDOWSDesktoptermc.asm(30): Include FileError!If anyone knows what is going on I would appreciate the help. Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

If it worked before, just try again. Or do a small change (edit a texture but don't change it really). After that it works for me most of the time.Also make sure you have no objects that are empty in the scene, the exporter doesn't like that :).ArnoMember NL2000 Teamhttp://home.wanadoo.nl/arno.gerretsen

Share this post


Link to post
Share on other sites

Arno,By empty do you mean no texture? I exported it before with a lot of missing textures and it worked fine. I'm just trying to get placement and size figured out. I cannot get this building to export at all! I can go and change/edit/tweak any and everything and the same damn error message pops up (see above)! I cannot fathom why this would work once and then all of a sudden, with no changes made to the building, start this error crap. I do not want to start over. I will destroy my computer before that happens. If you know of anything to do, let me know.Thanks

Share this post


Link to post
Share on other sites

Hi.Check the "keep files" in makemdl.Open with notepad your termc.asmGo to line 30. It should look like this :SCALE_AGL OBJECT_0_RETURN, 10000, 3, 131072, 00040A32Ah, 08444h, 00E94F918h, 0F48Ch, 0, 0The second parameter (10000 above) is the size. My guess is that the number you have is more than 65535. This is wrong. If this is the case, you most probably have wrong size per design unit, or your design is MASSIVE.Go to gmax Customize->Preferences->General and check that you have 1 unit= 1 meter.George

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this