Sign in to follow this  
Guest Claviateur

Size Restriction in GMAX/Makemdl?????

Recommended Posts

I'm working on a terminal building that is about 450 meters long. The first time I designed the building, I exported it fine to check its size in the FS world. There were several different objects within GMAX that comprised the building. Textures were NOT added to all objects. The building exported and showed up fine in FS2k2. I went back into GMAX to export again (so as to tweak the Lat/Long). Now I get the same damn error every time I try to export. Here is a sample of an error log I get:Generate BGL...Done!WARNING: radius is too big for crash dataGenerate crash tree 1 (4104 bytes) Assembling: C:WINDOWSDesktopterm.azmC:WINDOWSDesktopterm.asm(30) : error A2071: initializer magnitude too large for specified size SCALE_AGL(6): Macro Called From C:WINDOWSDesktopterm.asm(30): Include FileError!Now, I've started over trying to figure out what is wrong. I've built a simple rectangle and tried to export it. The funny thing is is that the rectangle will export just fine as long as its length is about 414 meters or shorter. The exact value is somewhere in between 414 and 414.5 meters. (I need 450 meters for my building) Is there some kind of size limitation withing GMAX/Makemdl? I cannot understand why it would export once and then start all this error crap when I didn't even change the model! I just used different Lat/Long. I've tried messing with textures as suggested by someone and that didn't help. I've tried to texture all of the objects within the building and that doesn't help. The only thing that makes sense is that there is a size issue. The fact that I can export as long as an object is below a certain length and because of the wording of the error makes me believe that the size is the problem. If ANYONE had seen this or knows what to do, please let me know.Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The beginning of the error message suggests that FS itself is unable to process too large a crash tree.What happens if you uncheck the Crash option when you export?

Share this post


Link to post
Share on other sites

I think that crash idea is a good one.I am working on a terminal and that has a totale size of 250 x 550 meters. It is made out of several objects and I compiles OK, with the crash option. But all my objects are shorter then the 410 meters you mention.ArnoMember NL2000 Teamhttp://home.wanadoo.nl/arno.gerretsen

Share this post


Link to post
Share on other sites

No dice, the Crash option has no effect. Still no export. I get the same magnitude error. Now I am not so sure about the size thing. I've tried several different times to model a rectangle in varying dimensions and there is no clear answer as to when a file will export correctly or not. Is Makemdl a piece of crap or is it just me? This is the first attempt I've made at using it and it seems terrible. It could be my system/settings/Windows/blah etc blah, but it is frustrating. Again it goes back to the fact that I EXPORTED THIS MODEL ONCE AND IT WORKED FINE! Then I just changed the Lat/Long in Makemdl and all the trouble started (and has yet to quit). Thanks for the suggestions and keep them coming if that is possible.

Share this post


Link to post
Share on other sites

HiCan you send me the two asm files that create the error ?Use the "Keep files" option in makemdl.Apart from that check the thread about framerates improvement.My opinion would be to export in 2-3 parts and never ever use crash detection. Check your frame rates with and without or check the masm code to understand why.George

Share this post


Link to post
Share on other sites

can you send the file that has the problem. or at least the LatLon and the box that has the problem.

Share this post


Link to post
Share on other sites

My experiments with big BGl file size exported from Gmax is that it took ages to finish the export process and in FS I got funny situations like for exemple when looking at the a/c in spot view where the scenery appears in the background, some aicraft parts twist and flip! I noticed that the graphic engine is not handling well the massive BGL size. By reducing the BGLs I did not have this problem. As for the crash thing, I do not use it because if we have a non rectangular object or many objects exported in 1 BGL, the crash will be done in a boxy way that will make you crash way before your object. So I disable itCheersMichel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this