Sign in to follow this  
Guest

Help with gmax

Recommended Posts

I have followed the instructions in the MS gmax scenery tutorial and copied the makemdl.exe file into c:gmaxplugins folder.Completed my terminal building and the texturing. I had a go in exporting into the FS but got this message'MakeMDL was not found. or failed to convert the model specified in c:program filesMicrosoft gamesFS2002ADDON SCENERYMyscenerysceneryterminal' to a MDL file. Check your systempath to ensure MakeMDL is on it.I thought I had followed the instructions to the word. Could someone please help me out.Your help is Most appreciatedLetats

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I got this cuz I'd downloaded a different version of gmax prior to buying fs2002, and not completely removed it.Once I did remove it and re-installed the new version, all was fine.Bob B

Share this post


Link to post
Share on other sites

Actually, it happens for some unknown reason once and awhile. Sometimes all it takes is a texture mapped the wrong way.I have two GMAX v 1.1's on my computer. One exports with the old Makemdl and the other, the new one. I have also found that the old Makemdl is more forgiving. Before starting over, try exporting the model with the old makemdl.Also, tick the ignore warnings and ignore Bad Normals boxes under options in Makemdlhttp://members.rogers.com/jkanold/jimlogo.gifhttp://members.rogers.com/eelvish/flyurl.gif

Share this post


Link to post
Share on other sites

Thank you for responding. I am using gmax version 1.1 and all of the configuratuion is as it should be. Initially I have created my basic model in Autocad 2000 and imported into gmax 1.1 in dxf format without any problems. Gradually I have became more confident with gmax and completed my model including texturing in gmax. Now I am tring to export it into FS and it is givig me this message'MakeMDL was not found. or failed to convert the model specified in c:program filesMicrosoft gamesFS2002ADDONSCENERYMyscenerysceneryterminal' to a MDL file. Check your system path to ensure MakeMDL is on it.'I do not think the problem is configuration but it might be the Autocad involvement???I have exported gmax only produced model into the FS without any problem. This worked ok.

Share this post


Link to post
Share on other sites

I have ticked the ignore warnings and gmax exported the model into FS. In FS I can see the reversed (or missing) polygons/faces and lack of texturing on some of the faces. Although I have initially ticked the perspective>configure>force 2 sided (viewport rendering options) in gmax. Every thing looks perfect in gmax.I can do the texturing again but how can I correct the flipped faces in gmax? without redesigning every thing again. How can I see the flipped faces in gmax? I think that Autocad dxf file format do not import into gmax correctly or all faces as should be?

Share this post


Link to post
Share on other sites

Hi Letats it sound like you may have some normals flipped to see if you do select your modifer tool and then select normal modifer and then select the polly that doesn't show in flight sim and check "flip normals" for that face and see if that does the trick. Dan

Share this post


Link to post
Share on other sites

I agree with Dan.There is no easy way to check the normals in Autocad, and the "2 sides" does not work when exporting to FS. What I do is do the DXF import into GMax, and then click on each object in turn and go to the "Modify...editable mesh...Face" menu and use the "Flip normal" mode to click on each face that needs to be reversed. If you maximize the perspective view and orbit around, it does not take too long to do.DerekOh, and by the way - uncheck the "perspective>configure>force 2 sided (viewport rendering options)" in gmax. You cannot tell which faces need to be flipped otherwise.

Share this post


Link to post
Share on other sites

I had my own experience with this same error message last night. Still bringing up all my apps after rebuilding my computer. Re-installed GMAX ver 1.1 and tried to export for the first time since the rebuild...got that dumb message.However, I found I could succeed with export of a simple box. I looked at the error log, and found it was confused over a scaling factor.I rebuilt the object from scratch and it worked fine. What I tried to do, and apparently has problems was this:Over a bmp background in top view I laid out a generic box with the x,y shape matching the building in the photo. Then I was going to each block, and making them a full model. To make it easy to work with, I tried to copy the block out into a new file, but I could find how to do that. So, I copied the whole file, and then deleted by inverse selection everything but that object. Then I finished the model with the remaining shaping and texturing, and it barfed on export.Again, when I built the object from scratch...it worked fine.Anyone know why the method I used would cause the dreaded, can't find makemdl.exe I'd appreciate it. Also, anyone know how to divide projects out (like save a part in fsds) to work on small files, and then to merge them back (like load a part in fsds)?Bob Bernstein

Share this post


Link to post
Share on other sites

Having flipped and corrected the poligons in the right direction, I have managed to import the scenery into FS. I had to do the 'unwrap UVW' on all the reversed poligons again, and cancelled the 2 sided texturing. I could see the model in its entirety in the FS but this time SOME TEXTURES DO NOT SHOW. All textures show in gmax but some do not show in FS. I checked texture mapping and all is ok. I am really puzzled. ?????? Also the same texture can be seen on one face but not on the other???HAS ANYONE EXPERIENCED THIS PROBLEM WITH THE TEXTURES?Once again your help will be appreciated?Letats

Share this post


Link to post
Share on other sites

I have managed to find out the reason why some of the textures did not show in FS in spite of showing in gmax.SIMPLE BASICS- The texture sizes were not in increments of 64x64, 128x128 or similar. Once they were corrected, they showed in FS immediately.Thank you for your help and sorry for the inconvenience. Soon you will have a great scenery upload!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this