Sign in to follow this  
Guest Firestriker

How does reflection work in a scenery?

Recommended Posts

Hey guys. I've marked the "Has Reflection Map" box while exporting my object, but the alpha channel is still showing transparency. Am I missing something here? Thanks, Leandro

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Or another method: Create a texture with an alpha channel masking in a tone of grey the areas you want to reflect. The darker the grey is the more reflection you will have. Then use the texture as a normal material in Gmax but then convert it to DXT3 and save it with a "_T" at the end in the texture folder of your scenery. For exemple: Termnial_T.bmp Cheers :)Michel

Share this post


Link to post
Share on other sites

Sorry Michel, only doing that doesn't work for me. You still have to add the material to the highlight tab and it has to be the same name as the texture you use for the "normal" texture.Arno


Member Netherlands 2000 Scenery Team[a href=http://home.wanadoo.nl/arno.gerretsen]http://home.wanadoo.nl/arno.gerretsen/banner.jpg[/a]

Share this post


Link to post
Share on other sites

The SDK says that you can do it Michel's way, but you have to check 'use transparency' in the bgl exporter. I can't confirm if that works though since I do it your way too, Arno.Cheers, Christian

Share this post


Link to post
Share on other sites

I assume you mean you have to check the "has reflectmap" option?I have done a little test, but when I try it that way I don't see any code for the reflection texture in the source file.I have also tried to use a seperate BMP for the reflection and that didn't work, the texture must have the same name as the base texture.Arno


Member Netherlands 2000 Scenery Team[a href=http://home.wanadoo.nl/arno.gerretsen]http://home.wanadoo.nl/arno.gerretsen/banner.jpg[/a]

Share this post


Link to post
Share on other sites

>I assume you mean you have to check the "has reflectmap" >option? yes, my mistake, I don't know why I keep mixing up reflectivity and transparency?!?>I have done a little test, but when I try it that way I >don't see any code for the reflection texture in the source >file. Obviously the SDK is wrong then. I think actually the old makemdl may support this. George did it this way (before the sdk was out) and I remember that I tried it too and it worked. Doesn't matter though, I like the other way better anyway.>I have also tried to use a seperate BMP for the reflection >and that didn't work, the texture must have the same name as >the base texture.Yes, it does. And with the "has reflectmap" way it also has to have "_T" at the end... Anyway, even if it does work, you have to keep selecting the checkbox every time you export, nothing to worry about when you assign the material to specular...Cheers, Christian

Share this post


Link to post
Share on other sites

Hi there,The only way I got it working (on an aircraft) was as arno suggests (but the texture must be the same for the higlight and specular and with the _T at the end) and it must be a dxt3 texture with the alpha channel defining the degree of reflex. I think that the sdk does not mention the use of dxt3 but looking at how Microsoft designed the default aircraft textures I would bet that this is the way to do it.Good luckjmf

Share this post


Link to post
Share on other sites

Yep, I do the same. The only difference is that it works fine without the _T for me.You can also make night textures without the _LM with GMax btw, I think that is the same idea.Arno


Member Netherlands 2000 Scenery Team[a href=http://home.wanadoo.nl/arno.gerretsen]http://home.wanadoo.nl/arno.gerretsen/banner.jpg[/a]

Share this post


Link to post
Share on other sites

In my experience getting reflections to work in scenery is no different that with aircraft. Just be sure your image file is DXT3 and has the *_t.bmp extension and that you compile with the "hasreflectmap" box checked in makemdl.exe. As you can see in the attached image I have been experimenting with making static aircraft. Noting special has been done in gWax other than to simply do the texture mapping.

Share this post


Link to post
Share on other sites

you are right with your method (method 1), I don't use the _t either, although I keep the _lm so I know it's the nightmap matching the main texture.However, the "reflectmap" checkbox approach needs the _t suffix (method 2). So, you can also use the "nightmap" checkbox if you have a _lm texture. As I said, it worked with the old makemdl, I never tested it with the new one though and method 1 is better anyway... I think method 1 didn't work with the old makemdl, because I remember trying that...Cheers, Christian

Share this post


Link to post
Share on other sites

>However, the "reflectmap" checkbox approach needs the _t >suffix (method 2). So, you can also use the "nightmap" >checkbox if you have a _lm texture. As I said, it worked >with the old makemdl, I never tested it with the new one >though and method 1 is better anyway... I think method 1 >didn't work with the old makemdl, because I remember trying >that... That's what I tested and method 2 doesn't seem to work with the latest MakeMDL (as it does for the night textures, only learned that some time ago :)). And method1 also worked here with the old MakeMDL, I use that method since my first tests with it.I think it is a bit confusing that there are such differences between the versions of MakeMDL, makes it hard to give the correct advice :).Arno


Member Netherlands 2000 Scenery Team[a href=http://home.wanadoo.nl/arno.gerretsen]http://home.wanadoo.nl/arno.gerretsen/banner.jpg[/a]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this