Sign in to follow this  
arno

Fsregen Problem

Recommended Posts

Hi everyone, I'm finding it very difficult to make fsregen work properly. I've just downloaded fsregen v0.20b. I also have the latest version of makemdl dated 05.04.02 (I hope if I'm correct about this). Unfortunately when I try to open the xx.asm file an error pops up saying that the 'file has already been processed'. Do I really have the correct or latest version of makemdl? If not, from where can I download it because that's what's available from microsoft's website. Am i doing something wrong? Please help!!!RegardsDaniel

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

tell us what files you get after your gmax export? I got this message before I learned to eliminate middleman...perhaps I have something slightly wrong, but I think it was either middleman or a previous verion of mademdl that provided a .asm file and a .azm file along with a bgl....Once I cleaned it up...using only the latest makemdl, I get an asm file, and a _0.asm file, and fsregen works great.Bob B

Share this post


Link to post
Share on other sites

I think this means that you haven't set up the materials correct for processing by FsRegen. Check the docs to see how they should be setup.Also if you "only" want the API feature, you need the Library Compiler, not the main window of FsRegen.Arno


Member Netherlands 2000 Scenery Team[a href=http://home.wanadoo.nl/arno.gerretsen]http://home.wanadoo.nl/arno.gerretsen/banner.jpg[/a]

Share this post


Link to post
Share on other sites

Thanks for your replies, but......Bob: First of all I don't use Middleman, just makemdl. When you say "latest version of makemdl", which version do you mean? I have v0.20b. Secondly, I do in fact get the files you mention, ie. I get *.bgl, *.asm and *_0.asm. But it still does not work, I'm still getting the error message, saying that it has already been processed.Arno: I have followed the docs and set up FSRegen accordingly. I don't think I have anything wrong there.Daniel

Share this post


Link to post
Share on other sites

v0.20b refers to FsRegen, not to make MakeMDL. The latest version comes with the MakeMDL SDK, but if you get the .asm and _0.asm file it seems you are already using it.Very strange, because it works fine for me. Maybe you can try a later version of FsRegen, I am using v0.31b.Arno


Member Netherlands 2000 Scenery Team[a href=http://home.wanadoo.nl/arno.gerretsen]http://home.wanadoo.nl/arno.gerretsen/banner.jpg[/a]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this