Sign in to follow this  
Guest

Animation with Gmax

Recommended Posts

Following some explanations found on this forum I exported a Gmax anim with an object called Tick18_ and it works. But it does not work corectly! It is fine at the beginning of the animation script but while the anim is running through the script (1024 frames) the object is moving by fits and starts more and more. At the end, the animation is really crap !!!! Do you know the reason ? How to get a constant animation without any jerks ?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

hey,I had that problem a while back...I had animated a tram that ran back and forth. If I remember correctly, I added more keyframes to smooth it out, however, I also remember monkeying with it for days.......and not being 100% happy with it.good luck,odog

Share this post


Link to post
Share on other sites

I am already using a 1024 frame animation. And longer the animation is and more important is the back and forth issue !!!Have you changed the frame rate value or something else ?Does someone else have more information about that issue ???

Share this post


Link to post
Share on other sites

>I am already using a 1024 frame animation. doesnt matter>Have you changed the frame rate value or something else ? add more "keyframes">Does someone else have more information about that issue ??? sorry if my info was not what you were looking for, but it will help the jumpies. Animation is not a switch you turn on and, poof, it works just the way you want, some complex animations are, well, complex. Have you done the animation tutorial?

Share this post


Link to post
Share on other sites

>>Have you changed the frame rate value or something else ? >>add more "keyframes" I assume you mean that you need to add more points on the keyframe animation? 1024 frames is the maximum length for the exporter and also the framerate is constant (18 frames a second), as this is the rate of the tick18 timer.Arno


Member Netherlands 2000 Scenery Team[a href=http://home.wanadoo.nl/arno.gerretsen]http://home.wanadoo.nl/arno.gerretsen/banner.jpg[/a]

Share this post


Link to post
Share on other sites

exactly...for some reason on long animations the tick18 command gets jumpy if only a few points/or keys are used. But as per Gmax, sometimes you can get away with it. I wonder if his problem could be more related to framerate issues?

Share this post


Link to post
Share on other sites

I will do more tests.Are you talking about the Gmax animation tutorial ? Yes of course I did the animation tutorial with Gmax a long time ago but the issue is not with Gmax but with FS2K2.Microsoftt has not released any animation SDK yet (apart from a beta one they removed I heard) this is also maybe because there is some issues with Gmax and animations.Yes only long animations have issues.I will try to had more keyframes as you mention and will see.I already tried to change the framerate value under gmax : nothing better.Has someone already managed to create a working long animation ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this