Sign in to follow this  
Guest

GMax to API Macro Help

Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

Try to take the following steps.First I assume that you have made the library source with FsRegen without problems. Then you can try the following to make the library BGL. Or save the ASM source (there is a button for that) and then compile it manual with BGLC or press the compile button, but then BGLC must be in the FsRegen folder (or the same folder as the asm source, I don't remember exactly). After this you should have a new BGL that is your library BGL. You can place this in the scenery folder of your project.Next step is to place the API with your design program (Airport, FSSC, etc). Do this in the normal way and then compile that scenery also and place it in the same folder where you put the library BGL.After this your scenery should work fine,Arno


Member Netherlands 2000 Scenery Team[a href=http://home.wanadoo.nl/arno.gerretsen]http://home.wanadoo.nl/arno.gerretsen/banner.jpg[/a]

Share this post


Link to post
Share on other sites

I feel a bit stupid admitting this but the problem was I had forgotten to put BGLC.exe in the same folder as FSREGEN. After I copied it to the proper folder everything worked perfect. :-doh Now all I need to do is figure out the new material editor in GMax 1.2 and I'll be a happy guy. I'll spend a bit more time with the help file before I bug anyone with that one.Thanks for the tutorial and thanks for setting me straight on what I was doing wrong.Pepe

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this