Sign in to follow this  
arno

GMax remove specular map

Recommended Posts

Got a problem. I want to remove a specular map from a material in GMax 1.2, but I can't find out how. In GMax 1.1 there was a nice button with a X on it to remove them, but that is gone. Anybody an idea?Arno


Member Netherlands 2000 Scenery Team[link:home.wanadoo.nl/arno.gerretsen]Arno's FlightSim World for scenery design hints, tips and other tricks...

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Arno, you see the checkboxes are still there, see the attachment, just uncheck the specular map box. If you return to material editor and don't find this screen, you need to click the "go up" one level button (circled in the second image), u are looking at a sub material box.

Share this post


Link to post
Share on other sites

Hi Bob,Thanks for the reply. I already tried that, but it doesn't work. After unckecking the box the specular map (reflection in FS) still appears in my source code. I think it is because the name of the map is still there and therefore MakeMDL still uses it.So I am searching something that can set it back to none :).Arno


Member Netherlands 2000 Scenery Team[link:home.wanadoo.nl/arno.gerretsen]Arno's FlightSim World for scenery design hints, tips and other tricks...

Share this post


Link to post
Share on other sites

what about just changing the 100% to 0% for the "amount"?B

Share this post


Link to post
Share on other sites

Nope, same effect (no effect thus). I think MakeMDL doesn't check for all those settings. Seems to only way then is to trash the material and create a new one, but I would prefer an easier method.Arno


Member Netherlands 2000 Scenery Team[link:home.wanadoo.nl/arno.gerretsen]Arno's FlightSim World for scenery design hints, tips and other tricks...

Share this post


Link to post
Share on other sites

Hi ArnoIn the material editor delete the specular texture (which should leave you with a diffuse texture in the material)?I think I had a similar problem in it took me a while to figure it out. The problem is that the gmax material editor is crippled, the 3dsmax editor is much easier to use...Cheers, Christian

Share this post


Link to post
Share on other sites

Thanks for the suggestion Christian, but I had a look again and can't find a way to delete that texture. You write it just that easy :D, can you be a little bit more specific maybe?Arno


Member Netherlands 2000 Scenery Team[link:home.wanadoo.nl/arno.gerretsen]Arno's FlightSim World for scenery design hints, tips and other tricks...

Share this post


Link to post
Share on other sites

he, he, if I could just remember *:-* I don't have gmax installed here and can't think of the right names, so I'll try to explain as good as I can...You have 2 material tools in gmax, lets name them tool 1 and 2. If you open tool 2 you get all the materials used, including the bitmaps used. Say like this:- material 1 | -- diffuse texture -- specular texture- material 2 | -- diffuse texture -- specular textureIf you double click (or just single click?) onto a material or a texture you get what you double clicked to show in tool 1. There you should be able to delete it. I'm 100% sure you can delete materials, but not 100% sure if this really works for textures.What doesn't work is trying to delete the texture by deselecting it from the list or trying to modify it in tool 1. You just click your way through the submenus (yoy probably know what I mean). However, if my trick above doesn't work, you may be able to disable the texture somewhere at the very beginning of tool 1. Maybe that's how I did it. Depending on how much spare time I have, I may try to reproduce what I did tonight...Hope that helps,Christian

Share this post


Link to post
Share on other sites

Thanks, this is what I tried.Tool 1 is the material editor and tool 2 the material navigator. When I double click on the specular texture in the navigator it indeed opens in the editor, but then I can't find a delete button anywhere (the delete button which is for the entire material is grayed out). I'll also continue searching, they must have hidden it somewhere :).Arno


Member Netherlands 2000 Scenery Team[link:home.wanadoo.nl/arno.gerretsen]Arno's FlightSim World for scenery design hints, tips and other tricks...

Share this post


Link to post
Share on other sites

I just tried to "replace" a specular map with another specular map, and it appeared to work just fine. Under bitmap parameters when you double click on the specular map in the navigator, you can reassign the path. Even if you can't delete it, you should be able to create a specular map that is 0% reflective (is that all black or all white...lol), and then change the map assignment to that map.Just a thought...Bob Bernstein

Share this post


Link to post
Share on other sites

I used another workaround now, I just deleted the alpha channel from the texture, then my reflections are also gone (and that is what I wanted). But I would also like to remove them from the source. Guess I have to do that with some tweaking of the source :).Arno


Member Netherlands 2000 Scenery Team[link:home.wanadoo.nl/arno.gerretsen]Arno's FlightSim World for scenery design hints, tips and other tricks...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this