Sign in to follow this  
Guest

polygon transparency with DXT3 with alpha channel

Recommended Posts

Hi everyone,I am designing some very detailed 3D vehicle models for FS2002 scenery. The original plan was to make them have 50% transparent windows, and a very basic dark interior with the main contours to be visible from outside. To make the windows transparent I used DXT3 format textures with alpha channel, where the alpha controls transparency instead of reflection. Upon texturing one side of the vehicle, I bumped into the first sign of a problem: the other side was not visible although the polygons that generate the other side were duplicated previously to face 'inside'. When applying the texture to the inside that should have been visible - they also use the transparecy for the windows - nothing showed up again. The strange thing is the wheels and rearview mirror for the other side are all there and visible.Anybody have an idea how to solve this?? Thanks in advanceRyan

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Ryan,In cases like these I make sure that inner faces are processed before the outer faces. I normally use DXT1 or even palettized 8-bit with "colorkey" transparency. In the basic interior texture(s) I set a transparency of 150 and in the outer texture(s) a transparency level of 50 or so.Regards, Luis

Share this post


Link to post
Share on other sites

Luis, thanks for the reply, appreciate your help.So what you're saying basically is that I should use DXT1 format textures with alpha channel? If you could describe more clearly for me what steps I'd need to take for a solutions that is known to work, I'd appreciate it very much, because I wasn't able to reproduce any results unfortunately. Thanks alot.Ryan

Share this post


Link to post
Share on other sites

If you want a semi-transparant window then DXT1 is not really an option (as that has only a 1 bit alpha channel). I think the first thing Luis said is the most important thing, make sure the drawing order is correct, so the inside must be drawn before the outside, otherwise you get those dissapearing parts.

Share this post


Link to post
Share on other sites

Then this may be the point I'm missing. How do I set the order of drawing the parts? I'm using FSDS. Thanks for the help.Ryan

Share this post


Link to post
Share on other sites

That's the difficult part, most design programs don't give that option. Ussually it is the order in which you draw them.In FSDS you can try to give the outside object the option "Uses transparant textures" that places it at the end of the drawing order (for simple objects this should be enough to solve the problem).

Share this post


Link to post
Share on other sites

I just looked through the help file of FSDS and found this:"FS Design Studio can automatically save a part file for each part in your project, and a text file containing a list of those filenames. This file can later be used as a merge control file. By manipulating the order of the files in this list, you can control the order that parts appear in your project. This is useful mainly to aircraft developers who want to override the default part sorting that FS Design Studio does when an aircraft is produced."I will give it a try and set the outside parts to be drawn only after the insides. Thanks for the help!Regards,Ryan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this